Bug 188621 - [PATCH] 3c59x tornado hangs with "NETDEV WATCHDOG: eth0: transmit timed out"
[PATCH] 3c59x tornado hangs with "NETDEV WATCHDOG: eth0: transmit timed out"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 15:55 EDT by David Moore
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 20:00:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Moore 2006-04-11 15:55:07 EDT
With both kernel-2.6.16-1.2080_FC5 and devel kernel kernel-2.6.16-1.2088_FC5, my
3c59x "Tornado" ethernet card will hang occasionally during periods of high
traffic.  The "hang" means that the system stops responding (hard lock) for
approximately 30 seconds, after which it recovers.  At this time, the kernel
produces an error message resembling the following:

Apr 11 01:00:38 pisces kernel: NETDEV WATCHDOG: eth0: transmit timed out
Apr 11 01:00:38 pisces kernel: eth0: transmit timed out, tx_status 00 status 8000.
Apr 11 01:00:38 pisces kernel:   diagnostics: net 04c6 media 8880 dma 000000a0
fifo 8000
Apr 11 01:00:38 pisces kernel:   Flags; bus-master 1, dirty 100120(8) current
100136(8)
Apr 11 01:00:38 pisces kernel:   Transmit list 2cb3a7a0 vs. ecb3a700.
Apr 11 01:00:38 pisces kernel: eth0: command 0x3002 did not complete! Status=0x9000
Apr 11 01:00:38 pisces kernel:   0: @ecb3a200  length 8000004e status 0000004e
Apr 11 01:00:38 pisces kernel:   1: @ecb3a2a0  length 8000004e status 0000004e
Apr 11 01:00:38 pisces kernel:   2: @ecb3a340  length 8000004e status 0000004e
Apr 11 01:00:38 pisces kernel:   3: @ecb3a3e0  length 80000036 status 00000036
Apr 11 01:00:38 pisces kernel:   4: @ecb3a480  length 8000004e status 0000004e
Apr 11 01:00:38 pisces kernel:   5: @ecb3a520  length 80000036 status 00000036
Apr 11 01:00:38 pisces kernel:   6: @ecb3a5c0  length 8000004e status 8000004e
Apr 11 01:00:39 pisces kernel:   7: @ecb3a660  length 80000036 status 80000036
Apr 11 01:00:39 pisces kernel:   8: @ecb3a700  length 80000042 status 00010042
Apr 11 01:00:39 pisces kernel:   9: @ecb3a7a0  length 80000042 status 00000042
Apr 11 01:00:39 pisces kernel:   10: @ecb3a840  length 80000042 status 00000042
Apr 11 01:00:39 pisces kernel:   11: @ecb3a8e0  length 8000004e status 0000004e
Apr 11 01:00:39 pisces kernel:   12: @ecb3a980  length 80000072 status 0c000072
Apr 11 01:00:39 pisces kernel:   13: @ecb3aa20  length 8000004e status 0000004e
Apr 11 01:00:39 pisces kernel:   14: @ecb3aac0  length 80000042 status 00000042
Apr 11 01:00:39 pisces kernel:   15: @ecb3ab60  length 8000004e status 0000004e

I have been able to fix the problem completely by applying the patch here:

http://lkml.org/lkml/2006/3/29/10

It looks like it's being committed upstream, but 2.6.16 was broken.
Comment 1 David Moore 2006-05-19 14:07:17 EDT
Any hope of getting this patch applied to the fedora kernel builds?  All the
recent kernel updates still have this bug.
Comment 2 Dave Jones 2006-09-10 20:00:31 EDT
Applied in 2.6.17 based updates.

Note You need to log in before you can comment on or make changes to this bug.