Bug 1886291 - [DOCS] Lack of the description of the ports and protocols for configuring the firewall
Summary: [DOCS] Lack of the description of the ports and protocols for configuring the...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Sara Thomas
QA Contact: Gaoyun Pei
Vikram Goyal
URL:
Whiteboard:
: 1851237 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-08 06:25 UTC by yhe
Modified: 2021-04-27 15:15 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-26 21:08:41 UTC
Target Upstream Version:
sarthoma: needinfo-
sarthoma: needinfo-


Attachments (Terms of Use)
email thread with proposed doc changes (266.60 KB, text/html)
2021-04-14 17:57 UTC, Sara Thomas
no flags Details

Description yhe 2020-10-08 06:25:17 UTC
Document URL: 
https://docs.openshift.com/container-platform/4.5/installing/install_config/configuring-firewall.html

Section Number and Name: 
Configuring your firewall for OpenShift Container Platform

Describe the issue: 
There is no description of what ports and protocols are used by those URLs, while the ports and protocols are necessary for configuring the firewall.

Suggestions for improvement: 
Add the description to specify which port and protocol is used by each URL.

Additional information:

Comment 2 Sara Thomas 2021-04-14 17:57:43 UTC
Created attachment 1771963 [details]
email thread with proposed doc changes

I'm adding this attachment of an email conversation with Tech Support and product mgmt, which details the changes I'm making to address this BZ. Tl;dr 443 and 80 are URL ports. *quay.io is added as a URL.

Comment 3 Sara Thomas 2021-04-15 15:19:39 UTC
Added ports and wildcard URL with a note about allowing the wildcard.

Direct link to doc preview: https://deploy-preview-31617--osdocs.netlify.app/openshift-enterprise/latest/installing/install_config/configuring-firewall.html
GitHub: https://github.com/openshift/openshift-docs/pull/31617

@rupatel@redhat.com -ready for you to review. Can you confirm that this change is for versions 4.5+?

Comment 4 Rupesh Patel 2021-04-15 15:31:52 UTC
(In reply to Sara Thomas from comment #3)
> Added ports and wildcard URL with a note about allowing the wildcard.
> 
> Direct link to doc preview:
> https://deploy-preview-31617--osdocs.netlify.app/openshift-enterprise/latest/
> installing/install_config/configuring-firewall.html
> GitHub: https://github.com/openshift/openshift-docs/pull/31617
> 
> @rupatel@redhat.com -ready for you to review. Can you confirm that this
> change is for versions 4.5+?

Looks fine to me (I think the port's requirement should be mentioned as "80 and 443" or "80,443". 
I mean both ports should be opened.

Comment 6 Gaoyun Pei 2021-04-26 13:18:37 UTC
LGTM, move the bug to verified

Comment 7 Sara Thomas 2021-04-26 21:08:41 UTC
Marking as closed. Link to live doc: https://docs.openshift.com/container-platform/4.7/installing/install_config/configuring-firewall.html

Comment 8 Kathryn Alexander 2021-04-27 15:15:34 UTC
*** Bug 1851237 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.