Bug 188651 - PUp needs abort/cancel option
PUp needs abort/cancel option
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 195466 217339 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-11 20:19 EDT by Gantry York
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 14:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff file for pirut (487 bytes, patch)
2006-06-25 16:41 EDT, Bryan Bell
no flags Details | Diff
diff patch for /usr/sbin/pup (175 bytes, patch)
2006-06-25 16:42 EDT, Bryan Bell
no flags Details | Diff
patch for /usr/lib/python2.4/site-packages/pirut/Progress.py (467 bytes, patch)
2006-06-25 16:44 EDT, Bryan Bell
no flags Details | Diff
patch for /usr/lib/python2.4/site-packages/pirut/__init__.py (919 bytes, patch)
2006-06-25 16:46 EDT, Bryan Bell
no flags Details | Diff

  None (edit)
Description Gantry York 2006-04-11 20:19:24 EDT
Description of problem:

When trying to install a lot of updates with PUp, PUp can seem to hang.  The
windows don't repaint.  Users are left wondering what is going on and will try
to abort/cancel by closing the window.  

This results in a "Force Quit" dialog box eventually comming up.  Then if you
force the quit, it will actually leave a process hanging even after the GUI goes
away.

If you try to do any other rpm type install you will get an error sayins
something has the rpm db locked.  The only way to recover from this is with a
kill -9 of the correct process.

It would be nice if the PUp interface could handle this better.

I think the hanging that is experienced is caused when the downloading takes so
long that the root password times out.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John D. Patota 2006-05-15 22:51:30 EDT
I to have experienced this hanging bug, but i dont think the program is going
completly dead...its more of a "watching the grass grow" or "waiting for paint
to dry" sensation in my case. 

I am installing gnome and apache with a sizable amount of their extras right now
and the download process is still going after almost 24 hours. Its not mission
critical that I get these packages installed so I'm riding the wave out to see
what happens. 

The only tangable output I have recieved, other than the successful download of
individual packages is the following: 

/usr/lib/python2.4/site-packages/pirut/Progress.py:158: GtkWarning:
_set_percentage: assertion `percentage >= 0 && percentage <= 1.0' f
  self.pbar.set_fraction(fract)

I dont know how much good any of that is but I thought i'd get it out there
Comment 2 Bryan Bell 2006-06-25 16:41:10 EDT
Created attachment 131505 [details]
diff file for pirut

Changes pirut, so the window is responsive when using the progress bar.
Comment 3 Bryan Bell 2006-06-25 16:42:44 EDT
Created attachment 131506 [details]
diff patch for /usr/sbin/pup

changes pup, so it is responsive when using the progress bar.
Comment 4 Bryan Bell 2006-06-25 16:44:43 EDT
Created attachment 131507 [details]
patch for /usr/lib/python2.4/site-packages/pirut/Progress.py

patch for the Progress bar file, so it's responsive(i.e. repaints the window on
the focus event).
Comment 5 Bryan Bell 2006-06-25 16:46:21 EDT
Created attachment 131508 [details]
patch for /usr/lib/python2.4/site-packages/pirut/__init__.py

patch for the YumGraphicalBase class, so it's responsive when using the
progress bar(i.e. repaints the window on the focus event).
Comment 6 Jeremy Katz 2006-10-30 13:41:57 EST
*** Bug 195466 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2006-11-27 17:48:41 EST
*** Bug 217339 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2007-09-11 14:18:10 EDT
Threading with yum introduces a number of interesting problems -- but
responsiveness should be a lot better for Fedora 8 and there's a cancel button
on all cancellable operations (ie, everything but the actual installation process)

Note You need to log in before you can comment on or make changes to this bug.