Bug 188690 - Liferea crashes in gdk_cairo_set_source_pixbuf() on FC5 x86_64.
Liferea crashes in gdk_cairo_set_source_pixbuf() on FC5 x86_64.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Brian Brock
:
: 211825 218236 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 01:47 EDT by Evgeniy Polyakov
Modified: 2007-12-01 18:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-01 18:15:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evgeniy Polyakov 2006-04-12 01:47:44 EDT
Description of problem:

Liferea (1.0.9, 1.0.8) crashes regulary on FC5 x86_64 system, stack dump shows
gdk_cairo_set_source_pixbuf() as the last entry.

Version-Release number of selected component (if applicable):

liferea-debuginfo.x86_64                 1.0.9-2.fc5            installed
liferea.x86_64                           1.0.9-2.fc5            installed

Previous 1.0.8 release crashed too.

How reproducible:

I would say 100% reproducible.
Just clicks between several feeds, liferea will crash quite fast.

Steps to Reproduce:
1. setup several feeds, which are updated periodically
2. when new updates are read, click between them until liferea crashed
  
Actual results:

Crash.

Expected results:

Proper work, I think?

Additional info:

I've installed debuginfo package and run liferea under gdb.
Here is an output:

(gdb) r
Starting program: /usr/bin/liferea-bin
[Thread debugging using libthread_db enabled]
[New Thread 46912496296544 (LWP 7901)]
A stale lockfile has been found, and was deleted.
Detaching after fork from child process 7904.
No browser module configured!
trying to load browser module GtkHTML2 (liblihtmlg.so)
[New Thread 1084229968 (LWP 7906)]
[New Thread 1094719824 (LWP 7907)]
[New Thread 1105209680 (LWP 7908)]
[New Thread 1115699536 (LWP 7909)]
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse
Unhandled property: 12 border-collapse

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496296544 (LWP 7901)]
0x000000331291b440 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
(gdb) bt
#0  0x000000331291b440 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
#1  0x0000003312d739b9 in gtk_cell_renderer_pixbuf_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x0000003312ef0232 in gtk_tree_view_column_focus_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x0000003312ef0e91 in gtk_tree_view_column_cell_is_visible () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x0000003312eebd46 in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x0000003312e23c7d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x0000003a0480b21d in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x0000003a0481b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x0000003a0481c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x0000003a0481c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x0000003312efd64e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#11 0x0000003312e1eb00 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x000000331293257a in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#13 0x000000331293270b in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#14 0x0000003312d9db05 in gtk_container_check_resize () from
/usr/lib64/libgtk-x11-2.0.so.0
#15 0x0000003a04426f7a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#16 0x0000003a0442a105 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#17 0x0000003a0442a42d in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#18 0x0000003312e1ece3 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#19 0x0000000000435dab in main (argc=1, argv=0x7fffff88a238) at main.c:285
(gdb)
Comment 1 Evgeniy Polyakov 2006-04-12 02:30:41 EDT
Well, I do think it can be not 100% related to gdk, and bug probably should be
opened against liferea package in extras, so I added bdpepple@ameritech.net to
Cc: list, as this e-mail is shown for bugs assigned to liferea.
Comment 2 Evgeniy Polyakov 2006-04-12 04:54:19 EDT
(gdb) bt
#0  0x000000331291b3b2 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
#1  0x0000003312d739b9 in gtk_cell_renderer_pixbuf_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x0000003312ef0232 in gtk_tree_view_column_focus_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x0000003312ef0e91 in gtk_tree_view_column_cell_is_visible () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x0000003312eebd46 in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x0000003312e23c7d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x0000003a0480b21d in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x0000003a0481b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x0000003a0481c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x0000003a0481c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x0000003312efd64e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#11 0x0000003312e1eb00 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x000000331293257a in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#13 0x000000331293265a in gdk_window_process_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#14 0x0000003312ee1c70 in gtk_tree_view_scroll_to_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#15 0x0000003312ee1e63 in gtk_tree_view_scroll_to_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#16 0x0000003312eed5bd in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#17 0x0000003312e23c7d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#18 0x0000003a0480b21d in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#19 0x0000003a0481b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#20 0x0000003a0481c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#21 0x0000003a0481c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#22 0x0000003312efd64e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#23 0x0000003312e1d91d in gtk_propagate_event () from /usr/lib64/libgtk-x11-2.0.so.0
#24 0x0000003312e1e951 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#25 0x000000331294665c in gdk_add_client_message_filter () from
/usr/lib64/libgdk-x11-2.0.so.0
#26 0x0000003a04426f7a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#27 0x0000003a0442a105 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#28 0x0000003a0442a42d in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#29 0x0000003312e1ece3 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#30 0x0000000000435dab in main (argc=1, argv=0x7ffffff71a18) at main.c:285


Another stack dump with the same end result, but different inner path.
Comment 3 Evgeniy Polyakov 2006-05-03 01:34:10 EDT
Stack dump with recent liferea-debug:
liferea.x86_64                           1.0.9-2.fc5            installed
liferea-debuginfo.x86_64                 1.0.10-2.fc5           installed


(gdb) bt
#0  0x00002aaaaaefe3b2 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
#1  0x00002aaaaab3b9b9 in gtk_cell_renderer_pixbuf_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x00002aaaaacb8922 in gtk_tree_view_column_focus_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x00002aaaaacb9581 in gtk_tree_view_column_cell_is_visible () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x00002aaaaacb4439 in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x00002aaaaabebc9d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x00002aaaab50221b in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x00002aaaab512548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x00002aaaab51314d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x00002aaaab513563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x00002aaaaacc5d3e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#11 0x00002aaaaabe6b20 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x00002aaaaaf1557a in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#13 0x00002aaaaaf1565a in gdk_window_process_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#14 0x00002aaaaacaa340 in gtk_tree_view_scroll_to_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#15 0x00002aaaaacaa533 in gtk_tree_view_scroll_to_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#16 0x00002aaaaacb5cad in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#17 0x00002aaaaabebc9d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#18 0x00002aaaab50221b in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#19 0x00002aaaab512548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#20 0x00002aaaab51314d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#21 0x00002aaaab513563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#22 0x00002aaaaacc5d3e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#23 0x00002aaaaabe591d in gtk_propagate_event () from /usr/lib64/libgtk-x11-2.0.so.0
#24 0x00002aaaaabe6971 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#25 0x00002aaaaaf2965c in gdk_add_client_message_filter () from
/usr/lib64/libgdk-x11-2.0.so.0
#26 0x00002aaaab86a03a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#27 0x00002aaaab86d1b5 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#28 0x00002aaaab86d4dd in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#29 0x00002aaaaabe6d03 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#30 0x0000000000435dab in main ()
Comment 4 Brian Pepple 2006-05-03 08:24:00 EDT
Have you tried updating to the most recent version of liferea?

* Sat Apr 22 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.10-2
- Update to 1.0.10.
- Remove *.la, instead of excluding.
- Delete original desktop file in desktop-file-install call.

I'm also going to assign this to liferea, because I belive that is where the
problem lies.
Comment 5 Evgeniy Polyakov 2006-05-04 03:33:23 EDT
(In reply to comment #4)
> Have you tried updating to the most recent version of liferea?
> 
> * Sat Apr 22 2006 Brian Pepple <bdpepple@ameritech.net> - 1.0.10-2
> - Update to 1.0.10.
> - Remove *.la, instead of excluding.
> - Delete original desktop file in desktop-file-install call.
> 
> I'm also going to assign this to liferea, because I belive that is where the
> problem lies.

This update does not live in extras.
Only following packages are there:

liferea.x86_64                           1.0.9-2.fc5            installed
liferea-debuginfo.x86_64                 1.0.10-2.fc5           installed

I've just setup 
liferea                 x86_64     1.0.10-3.fc6     extras-development
from extras-development to see if it fixes the problem.
Comment 6 Michael Schwendt 2006-05-04 04:16:20 EDT
Sure it does. You even have its -debuginfo package installed.
Look, here is the 1.0.10-2.fc5 version in the master repository
since Apr 25th:

http://fedoraproject.org/extras/5/x86_64/liferea-1.0.10-2.fc5.x86_64.rpm
Comment 7 Evgeniy Polyakov 2006-05-04 04:28:36 EDT
Then something is screwed in yum repos.
I've just run yum update and got following output:

Setting up Update Process
Setting up repositories
extras-source                                                        [1/5]
extras-source             100% |=========================|  951 B    00:00
core                                                                 [2/5]
core                      100% |=========================| 1.3 kB    00:00
extras-debuginfo                                                     [3/5]
extras-debuginfo          100% |=========================|  951 B    00:00
updates                                                              [4/5]
updates                   100% |=========================|  951 B    00:00
extras                                                               [5/5]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 523 kB    00:09
extras-sou: ################################################## 1904/1904
Added 23 new packages, deleted 8 old in 1.69 seconds
primary.xml.gz            100% |=========================| 229 kB    00:04
extras-deb: ################################################## 1329/1329
Added 17 new packages, deleted 7 old in 1.83 seconds
primary.xml.gz            100% |=========================| 255 kB    00:00
updates   : ################################################## 822/822
Added 413 new packages, deleted 0 old in 5.26 seconds
primary.xml.gz            100% |=========================| 1.0 MB    00:07
extras    : ################################################## 2971/2971
Added 36 new packages, deleted 14 old in 5.46 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libsndfile.x86_64 0:1.0.15-1.fc5 set to be updated
---> Package libsamplerate.x86_64 0:0.1.2-4.fc5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 libsamplerate           x86_64     0.1.2-4.fc5      extras            152 k
 libsndfile              x86_64     1.0.15-1.fc5     extras            208 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       2 Package(s)
Remove       0 Package(s)
Total download size: 361 k
Is this ok [y/N]:


As you can see new liferea package is not found in extras by "yum update".

Here is output of yum install liferea*:

$sudo yum install liferea*
Setting up Install Process
Setting up repositories
extras-source                                                        [1/5]
core                                                                 [2/5]
extras-debuginfo                                                     [3/5]
updates                                                              [4/5]
extras                                                               [5/5]
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

I've run it just after updated all core packages above.

I use following URL for extras repository:
mirrorlist=http://fedora.redhat.com/download/mirrors/fedora-extras-$releasever


I will install new version manually to see if it fixes the bug.
Comment 8 Evgeniy Polyakov 2006-05-04 08:09:02 EDT
Bug is still there.
Installed Packages
liferea.x86_64                           1.0.10-2.fc5           installed
liferea-debuginfo.x86_64                 1.0.10-2.fc5           installed


Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912496296544 (LWP 647)]
0x000000377d61b3b2 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
(gdb) bt
#0  0x000000377d61b3b2 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
#1  0x000000377d1739b9 in gtk_cell_renderer_pixbuf_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x000000377d2f0922 in gtk_tree_view_column_focus_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x000000377d2f1581 in gtk_tree_view_column_cell_is_visible () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x000000377d2ec439 in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x000000377d223c9d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x000000377c50b21b in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x000000377c51b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x000000377c51c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x000000377c51c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x000000377d2fdd3e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#11 0x000000377d21eb20 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x000000377d63257a in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#13 0x000000377d63270b in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#14 0x000000377d19dad5 in gtk_container_check_resize () from
/usr/lib64/libgtk-x11-2.0.so.0
#15 0x000000377c32703a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#16 0x000000377c32a1b5 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#17 0x000000377c32a4dd in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#18 0x000000377d21ed03 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#19 0x0000000000435ddb in main (argc=1, argv=0x7fffffb36f08) at main.c:285
Comment 9 Evgeniy Polyakov 2006-05-05 02:38:45 EDT
Another backtrace from the latest liferea from extras:

#0  0x000000377d61b3b2 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
#1  0x000000377d1739b9 in gtk_cell_renderer_pixbuf_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x000000377d2f0922 in gtk_tree_view_column_focus_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x000000377d2f1581 in gtk_tree_view_column_cell_is_visible () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x000000377d2ec439 in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x000000377d223c9d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x000000377c50b21b in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x000000377c51b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x000000377c51c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x000000377c51c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x000000377d2fdd3e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#11 0x000000377d21eb20 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x000000377d63257a in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#13 0x000000377d63265a in gdk_window_process_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#14 0x000000377d2e2340 in gtk_tree_view_scroll_to_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#15 0x000000377d2e2533 in gtk_tree_view_scroll_to_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#16 0x000000377d2edcad in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#17 0x000000377d223c9d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#18 0x000000377c50b21b in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#19 0x000000377c51b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#20 0x000000377c51c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#21 0x000000377c51c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#22 0x000000377d2fdd3e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#23 0x000000377d21d91d in gtk_propagate_event () from /usr/lib64/libgtk-x11-2.0.so.0
#24 0x000000377d21e971 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#25 0x000000377d64665c in gdk_add_client_message_filter () from
/usr/lib64/libgdk-x11-2.0.so.0
#26 0x000000377c32703a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#27 0x000000377c32a1b5 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#28 0x000000377c32a4dd in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#29 0x000000377d21ed03 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#30 0x0000000000435ddb in main (argc=1, argv=0x7fffff83e368) at main.c:285
Comment 10 Michael Schwendt 2006-05-05 05:42:27 EDT
All these backtraces are no different. They just make this ticket
longer and less readable.

May I also point out that nothing in the backtraces indicates that
it is bug directly in Liferea. The entire backtrace stays in gtk2.
Comment 11 Evgeniy Polyakov 2006-05-05 06:00:06 EDT
It is the only way to show, that bug is still there and must be fixed.

Bug was initially opened against gdk-pixbuf, but since there are no applications
except liferea that crash in my FC5 setup, I agreed that it might be liferea bug.
Comment 12 Evgeniy Polyakov 2006-05-11 09:01:14 EDT
I've install the latest liferea package from extras-development and still have
the same bug.

liferea.x86_64                           1.0.11-3.fc6           installed
liferea-debuginfo.x86_64                 1.0.11-3.fc6           installed
Comment 13 Evgeniy Polyakov 2006-05-23 02:21:45 EDT
Bug is 100% reproducable when searching for nonexistent set of symbols like
"qweqweqeqwe".

liferea.x86_64                           1.0.11-3.fc6           installed
liferea-debuginfo.x86_64                 1.0.11-3.fc6           installed

(gdb) bt
#0  0x00000036c911b440 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
#1  0x00000036c8a739b9 in gtk_cell_renderer_pixbuf_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x00000036c8bf0922 in gtk_tree_view_column_focus_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x00000036c8bf1581 in gtk_tree_view_column_cell_is_visible () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x00000036c8bec439 in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x00000036c8b23c9d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x00000036c640b21b in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x00000036c641b548 in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x00000036c641c14d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x00000036c641c563 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x00000036c8bfdd3e in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#11 0x00000036c8b1eb20 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x00000036c913257a in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#13 0x00000036c913270b in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#14 0x00000036c8a9dad5 in gtk_container_check_resize () from
/usr/lib64/libgtk-x11-2.0.so.0
#15 0x00000036c622703a in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#16 0x00000036c622a1b5 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#17 0x00000036c622a4dd in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#18 0x00000036c8b1ed03 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#19 0x0000000000435e0b in main (argc=1, argv=0x7fffffcf40a8) at main.c:285
Comment 14 Evgeniy Polyakov 2006-06-20 08:01:13 EDT
Bug is still there with the latest package from extras
liferea.x86_64                           1.0.15-2.fc5           installed
liferea-debuginfo.x86_64                 1.0.15-2.fc5           installed
Comment 15 Evgeniy Polyakov 2006-06-21 06:05:58 EDT
When running under GDB and doing search for non existent set of symbols (like
"abcd1234"), it crashes and screen contains information that there are "0 search
results for "abcd1234".

The more I think about this bug the more I suspect it is not 100% liferea bug,
at least gtk could provide some hints or assertions about data provided by liferea.
So I've added mclasen@redhat.com to Cc: list so Matthias Clasen could comment
bout backtrace.

Backtrace looks like all above:
(gdb) bt
#0  0x00000039fa71b3c0 in gdk_cairo_set_source_pixbuf () from
/usr/lib64/libgdk-x11-2.0.so.0
#1  0x00000039fab739b9 in gtk_cell_renderer_pixbuf_new () from
/usr/lib64/libgtk-x11-2.0.so.0
#2  0x00000039facf09c2 in gtk_tree_view_column_focus_cell () from
/usr/lib64/libgtk-x11-2.0.so.0
#3  0x00000039facf1621 in gtk_tree_view_column_cell_is_visible () from
/usr/lib64/libgtk-x11-2.0.so.0
#4  0x00000039facec549 in gtk_tree_view_get_hadjustment () from
/usr/lib64/libgtk-x11-2.0.so.0
#5  0x00000039fac23e2d in gtk_marshal_BOOLEAN__VOID () from
/usr/lib64/libgtk-x11-2.0.so.0
#6  0x00000039f9d0b22a in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#7  0x00000039f9d1b98d in g_signal_override_class_closure () from
/usr/lib64/libgobject-2.0.so.0
#8  0x00000039f9d1c59f in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#9  0x00000039f9d1c9b3 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#10 0x00000039facfddee in gtk_widget_get_default_style () from
/usr/lib64/libgtk-x11-2.0.so.0
#11 0x00000039fac1ecb0 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x00000039fa7325aa in gdk_window_is_viewable () from
/usr/lib64/libgdk-x11-2.0.so.0
#13 0x00000039fa73273b in gdk_window_process_all_updates () from
/usr/lib64/libgdk-x11-2.0.so.0
#14 0x00000039fab9da15 in gtk_container_check_resize () from
/usr/lib64/libgtk-x11-2.0.so.0
#15 0x00000039f9b26cca in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#16 0x00000039f9b29e45 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#17 0x00000039f9b2a16d in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#18 0x00000039fac1ee93 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#19 0x00000000004358ed in main (argc=1, argv=0x7ffffff9c138) at main.c:285
Comment 16 Brian Pepple 2006-10-23 10:22:33 EDT
*** Bug 211825 has been marked as a duplicate of this bug. ***
Comment 17 Tim Waugh 2006-10-30 11:03:39 EST
Seeing this too in FC6.  liferea-1.0.25-1.fc6
Comment 18 Brian Pepple 2006-12-03 18:46:46 EST
*** Bug 218236 has been marked as a duplicate of this bug. ***
Comment 19 Tim Waugh 2007-03-06 09:19:02 EST
Still there in 1.0.26-3.fc6.  Is anyone looking at this, or managed to reproduce it?
Comment 20 Brian Pepple 2007-07-14 22:04:24 EDT
Are you seeing this bug in liferea-1.2.* in F7 and Rawhide?
Comment 21 Evgeniy Polyakov 2007-07-15 03:21:17 EDT
I removed FC, so I can not confirm if this bug still exists or not.
Comment 22 Tim Waugh 2007-07-16 04:45:25 EDT
Not since I switched to Mozilla for the renderer.
Comment 23 Brian Pepple 2007-12-01 18:15:38 EST
Closing since the 1.4.x branch has been pushed.  Please reopen if this is still
being experienced.

Note You need to log in before you can comment on or make changes to this bug.