Bug 188691 - chcon -t textrel_shlib_t LIBRARY issue (reporting as bugzilla)
chcon -t textrel_shlib_t LIBRARY issue (reporting as bugzilla)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 01:55 EDT by Ihab
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 11:57:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ihab 2006-04-12 01:55:03 EDT
Description of problem: gyach pY! voice chat module receives the following error
ImportError: /usr/local/share/gyach/pyvoice/pytspc.so: cannot restore segment
prot after reloc: Permission denied

dmesg shows the following:
audit(1144820514.950:85): avc:  denied  { execmod } for  pid=20595 comm="python"
name="pytspc.so" dev=dm-0 ino=11361843 scontext=user_u:system_r:unconfined_t:s0
tcontext=system_u:object_r:lib_t:s0 tclass=file

It prohibits the user from launching the voice-chat module in the gyach application.

Version-Release number of selected component (if applicable): 


How reproducible: Obtain gyach 1.0.7 (current stable), enable voice chat, then
launch the pY! voice chat module.


Steps to Reproduce:
1.Obtain Gyach 1.0.7 (current stable)
2.Enable voice chat
3.Launch pY! Voice Chat Module
  
Actual results: 
audit(1144820514.950:85): avc:  denied  { execmod } for  pid=20595 comm="python"
name="pytspc.so" dev=dm-0 ino=11361843 scontext=user_u:system_r:unconfined_t:s0
tcontext=system_u:object_r:lib_t:s0 tclass=file


Expected results:
It should be allowed, I'm submitting this because it was recommended at
http://fedora.redhat.com/docs/selinux-faq-fc5/#id2980963

Additional info: I was able to fix it with the suggestion on that selinux faq
page by issueing the following command:
chcon -t textrel_shlib_t /usr/local/share/gyach/pyvoice/pytspc.so
Comment 2 Daniel Walsh 2006-05-09 11:57:03 EDT
This should be reported as a bug to the maintainers of gyach with a link to the
following page

http://people.redhat.com/~drepper/selinux-mem.html

They should fix the library.  Since this is not in Fedora and you have a good
work around I will not fix the policy, please have the maintainers fix the library.

Note You need to log in before you can comment on or make changes to this bug.