This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188695 - [fc5] XIM problems for bn_IN on KDE desktop
[fc5] XIM problems for bn_IN on KDE desktop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 05:55 EDT by Runa Bhattacharjee
Modified: 2013-03-03 21:20 EST (History)
3 users (show)

See Also:
Fixed In Version: scim-1.4.4-32.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-31 06:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Runa Bhattacharjee 2006-04-12 05:55:27 EDT
Description of problem:

Scim does not get activated on KDE for bn_IN locale. The kde-applications like
kedit, kwrite etc. cannot use scim alhtough Gnome applications like gedit work
fine even in the KDE desktop environment

Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1. Log in from FC-5 gdm with session - KDE and language as Bengali India
2. Open kedit from the terminal or from the menu
3. Press Ctrl+space to activate scim 
  
Actual results:

the scim toolbar does not appear on the bottom right corner

Expected results:

scim toolbar should appear at the bottom right corner to allow the user to
choose the appropriate keyboard layout

Additional info:
gnome applications like gedit allow using scim even from within KDE.
Comment 1 Jens Petersen 2006-04-12 07:28:52 EDT
This is quite strange, IM seems to work ok with
bn_BD, gu_IN, pa_IN and ta_IN at least.
Comment 2 kushaldas@gmail.com 2006-05-12 02:20:05 EDT
Can not use scim in any KDE application.
Comment 3 Jens Petersen 2006-08-01 23:40:18 EDT
Is this still a problem?
Comment 4 Runa Bhattacharjee 2006-08-02 00:01:33 EDT
Jens,
Found the following:

* Works for K-Apps (tried kate, kwrite, konqueror,kbabel) in KDE
* Does not work  for gnome applications in KDE
* Does not work on Firefox

Could not check on evolution as it failed to start due to some other bug
Comment 5 Jens Petersen 2006-08-02 00:17:01 EDT
For FC5?
Comment 6 Jens Petersen 2006-08-02 00:18:57 EDT
The results in comment 4 seem to be the opposite of the original report...
Comment 7 Runa Bhattacharjee 2006-08-02 01:35:59 EDT
(In reply to comment #5)
> For FC5?

Rawhide build.
Comment 8 Jens Petersen 2006-08-07 22:12:33 EDT
XIM seems a bit unstable sometimes on the KDE desktop - not sure
if it is related to SCIM though.

I can input Bengali ok in kde apps on the KDE on FC5 - users may have to
make sure that the default map for bengali is set to Bengali before
starting if bug 197058 is relevant.  Also works fine for me for gtk apps
on the KDE desktop.

If you see something different for fc6/rawhide please open another bug
for that.
Comment 9 Satyabrata Maitra 2006-08-31 06:24:04 EDT
SCIM is now getting activated for bn_IN Locale. The problem is fixed now.

Component Version Tested : scim-1.4.4-32.fc6 (rawhide)

Note You need to log in before you can comment on or make changes to this bug.