Bug 188696 - Help and tutorial links to local files don't work
Help and tutorial links to local files don't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grace (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 06:42 EDT by L
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.1.20-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 11:50:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L 2006-04-12 06:42:56 EDT
Description of problem:
Clicking any menu item under Help except for Comments and About does not work. 
A Mozilla window (not my default browser) spawns and tries to resolve www.doc.com

Version-Release number of selected component (if applicable):
grace-5.1.19-4.fc5

How reproducible:
very

Steps to Reproduce:
1. Click any item in Help, other than About or Comments
  
Actual results:
Mozilla browser window spawns with the URL set to (for example)
doc/UsersGuide.html and can't resolve www.doc.com

Expected results:
my default browser (Firefox) opens local file with URL (for example)
file:///usr/share/doc/grace-5.1.19/doc/UsersGuide.html

Additional info:
The files are present in /usr/share/doc/grace-5.1.19, and installed via the RPM.

RPM installed via yumex, with the following dependencies:  fftw2, nedit (?), t1lib

PS  This is my first bug report so.. please correct my mistakes!
PPS  (just curious)  Why is nedit required?  Is this a bug?
Comment 1 José Matos 2006-04-13 07:14:02 EDT
(In reply to comment #0)
> ...
> The files are present in /usr/share/doc/grace-5.1.19, and installed via the 
RPM.
> 
> RPM installed via yumex, with the following dependencies:  fftw2, nedit (?), 
t1lib
> 
> PS  This is my first bug report so.. please correct my mistakes!

  There is no mistake. :-)
  I have changed the help viewer to be htmlview (that will translate to 
firefox on most systems).

  I made the changes yesterday and I will require a build soon.

> PPS  (just curious)  Why is nedit required?  Is this a bug?

  We needed an editor for grace, I have decided to go nedit since it uses the 
same toolkit as grace. Nothing really fundamental going on... ;-)
Comment 2 L 2006-04-19 02:25:37 EDT
Same problem after upgrade to grace-5.1.19-5.fc5

--> The problem is with the path, I think.  Should 'configure' with a switch
that defines /usr/share/doc/grace-5.1.19/doc/ as part of the document path.

Updated details below:

Steps to Reproduce:
1. Click any item in Help, other than About or Comments (they still both work. 
Comments must still work because it explicitely defines a full http path)
  
Actual results:
Click anything except Examples:  Nothing happens.  No mozilla spawn now. 
Click on Examples:  A console window pops up, displaying "Can't stat file
examples/example.agr"  [[Note, the console doesn't report the full path!]]

Expected results:
my default browser (Firefox) opens local file with URL (for example)
file:///usr/share/doc/grace-5.1.19/doc/UsersGuide.html

Additional info:

Just for completeness, the following packages are on my machine:

grace-5.1.19-5.fc5
htmlview-3.0.0-14
firefox-1.5.0.1-9
mozilla-1.7.12-5

Thanks!
Comment 3 Terri Fischer 2006-07-25 15:31:09 EDT
Suggested package changes to get grace help to work:

For the rpm, if you (1) create an /etc/profile.d file for the package that sets
the environment variable GRACE_HOME to point to /usr/share/grace and (2) make a
symlink /usr/share/grace/doc that points to the /usr/share/doc/grace-$ver/doc
directory, I think grace will be happy.

I'm using grace-5.1.20-1.fc5 at the moment.

Thanks.
Comment 4 José Matos 2006-09-12 07:21:27 EDT
I am sorry for taking so long to answer. :-)
I took August for some well deserved holidays.

I removed the profile.d file since it was not necessary in a previous version.
I am still convinced that it is not necessary but I got the wrong solution at 
that time.

I have passed explicitly the path this time. Please test grace-5.1.20-2.fc5 
that should be out soon.
Comment 5 José Matos 2006-09-13 06:46:48 EDT
The update is out and it works for me.

If I don't get any feedback in the next week I will close this bug as fixed in 
current release. I will do it as well if the feedback is positive. :-)
Comment 6 Terri Fischer 2006-09-15 08:13:04 EDT
The new grace-5.1.20-2.fc5 rpm hit my repository last night.  Installed this
morning. When I push Help->UsersGuide I get

file:///usr/share/doc/grace-5.1.20//usr/share/grace/doc/UsersGuide.html

Firefox can't find the file at
/usr/share/doc/grace-5.1.20//usr/share/grace/doc/UsersGuide.html

Same sort of thing for Tutorial and FAQ.
Comment 7 José Matos 2006-09-16 03:58:11 EDT
(In reply to comment #6)
> The new grace-5.1.20-2.fc5 rpm hit my repository last night.  Installed this
> morning. When I push Help->UsersGuide I get
> 
> file:///usr/share/doc/grace-5.1.20//usr/share/grace/doc/UsersGuide.html

 Terri, it looks like this is a result from your changes in comment #3.
This would explain why the directory path is duplicated.

  Could you remove the changes and see if it works?

> Firefox can't find the file at
> /usr/share/doc/grace-5.1.20//usr/share/grace/doc/UsersGuide.html
> 
> Same sort of thing for Tutorial and FAQ.

  This is consistent with the previous explanation. :-)
Comment 8 Terri Fischer 2006-09-19 09:02:12 EDT
The env variable was already gone but I'd forgotten the symlink. Removed that
and it works great.  Sorry for the extra round and thanks for the changes. T.
Comment 9 José Matos 2006-09-19 11:50:05 EDT
(In reply to comment #8)
> and it works great.  Sorry for the extra round and thanks for the changes. 
T.

No problem. :-)


Note You need to log in before you can comment on or make changes to this bug.