Bug 188706 - Corrupted screen for Radeon R100 PCI w/compositing manager on
Corrupted screen for Radeon R100 PCI w/compositing manager on
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 09:51 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 08:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ATI R100 PCI screenshot w/compositing manager enabled (108.99 KB, image/png)
2006-04-12 09:52 EDT, Joachim Frieben
no flags Details
ATI R100 PCI gnome-terminal screenshot w/compositing manager enabled at 16bpp (65.22 KB, image/png)
2006-04-24 14:07 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2006-04-12 09:51:47 EDT
Description of problem:
The "AIGLX" extension to "Xorg" leads to a corrupted rendering of the
"GNOME" desktop when the "metacity" compositing manager is enabled.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.0-1

How reproducible:
Always

Steps to Reproduce:
1. Switch on "composite" extension in "xorg.xonf".
2. Enable compositing manager in "metacity".
  
Actual results:
The screen is all white with drop shadows. The menus become
visible on opening. So "gnome-terminal" and other applications
when launched from the "GNOME" menu as the attached screenshot
shows. Effects do actually work ("fluid").

Expected results:
The desktop should be rendered correctly.

Additional info:
System is FC5 with updated packages "mesa-libGL-6.5-3" and
"xorg-x11-server-Xorg-1.0.99.901-1" in addition to the
also upgraded "radeon" driver package.
Comment 1 Joachim Frieben 2006-04-12 09:52:44 EDT
Created attachment 127659 [details]
ATI R100 PCI screenshot w/compositing manager enabled
Comment 2 Joachim Frieben 2006-04-24 14:07:24 EDT
Created attachment 128159 [details]
ATI R100 PCI gnome-terminal screenshot w/compositing manager enabled at 16bpp
Comment 3 Mike A. Harris 2006-05-23 08:53:45 EDT
If this issue turns out to still be reproduceable in the latest
rawhide builds, please file a bug report in the X.Org bugzilla
located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.


Note You need to log in before you can comment on or make changes to this bug.