Bug 188731 - Banshee Currently Crashes on Startup
Banshee Currently Crashes on Startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 13:23 EDT by teamwassily
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 22:29:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description teamwassily 2006-04-12 13:23:51 EDT
Description of problem:

As of today, April 12th (wednesday), Banshee crashes on startup.  It's been
working for me (with bugs, all already reported) since FC5 was released but now
it won't start.  I get an Error Dialog that says "The Application Banshee has
quit unexpectedly." with the usual "inform developers... or restart now..." notice.

Yesterday, April 11th, I decided to enablerepo=updates-testing to get the latest
Beagle (0.2.4) and as far as I can tell it must've been this update that mucked
up Banshee.  (Today's updates-testing is broken)

I was actually able to load Banshee ONCE, for some freak reason out of a dozen
or so failed attempts.  I exited, and tried to reload Banshee with out success.

It would be good to get the latest version of Banshee in updates, but I don't
think this is the problem.

Version-Release number of selected component (if applicable):
0.10.8

How reproducible:
almost always

Steps to Reproduce:
1. Start Banshee from Gnome menu
2. Watch it crash and burn
3.
  
Actual results:
crashes

Expected results:
starts

Additional info:
I created a brand new user called "testme" and tried to start Banshee and the
exact same problem occurred.

So that to me rules out any corruption that my regular user account could've
had.  It seems to be the updates-testing update. :)
Comment 1 teamwassily 2006-04-12 20:31:06 EDT
To make this bug more interesting, here's what happens if I run banshee from
Gnome Terminal 2.14.1 and it fails to load:

$ banshee
Warning: [4/12/2006 8:33:53 PM] (Cannot connect to NetworkManager) - An
available, working network connection will be assumed
Debug: [4/12/2006 8:33:54 PM] (Default player engine) - GStreamer 0.10
Debug: [4/12/2006 8:33:54 PM] (Audio CD Core Initialized) -
Warning: [4/12/2006 8:33:54 PM] (Could not connect to D-Bus) - D-Bus support
will be disabled for this instance: An SELinux policy prevents this sender from
sending this message to this recipient (rejected message had interface
"org.freedesktop.DBus" member "Hello" error name "(unset)" destination
"org.freedesktop.DBus")

(Banshee:5463): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling
gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the
data stream to the loader before dropping the last reference.
Building initial DAAP database from local library...
Starting DAAP Server
5463: assertion failed "!(connection)->have_connection_lock" file
"dbus-connection.c" line 978 function _dbus_connection_acquire_io_path




and here's what happens when Banshee actually loads and exits naturally:

$ banshee
Warning: [4/12/2006 8:36:08 PM] (Cannot connect to NetworkManager) - An
available, working network connection will be assumed
Debug: [4/12/2006 8:36:09 PM] (Default player engine) - GStreamer 0.10
Debug: [4/12/2006 8:36:09 PM] (Audio CD Core Initialized) -
Warning: [4/12/2006 8:36:10 PM] (Could not connect to D-Bus) - D-Bus support
will be disabled for this instance: An SELinux policy prevents this sender from
sending this message to this recipient (rejected message had interface
"org.freedesktop.DBus" member "Hello" error name "(unset)" destination
"org.freedesktop.DBus")

(Banshee:5505): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling
gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the
data stream to the loader before dropping the last reference.
Building initial DAAP database from local library...
Starting DAAP Server
Scanning library for tracks to update
Done scanning library
Processing track queue for pending queries
Done processing track queue




Hope that helps!


Comment 2 teamwassily 2006-04-12 20:34:06 EDT
I'm completely up to date with the [updates-testing] repository for FC5.  The
problem seems to occur after the Starting DAAP Server.
Comment 3 teamwassily 2006-04-12 23:52:00 EDT
Is an SELinux policy being worked on for Banshee?  Would it be possible to have
a policy that prohibits any network activity, and then if needed for the
audioscrobbler plugin or other such plugins, then have a loadable policy module
that would allow network support?  It's my understanding that the refpolicy
allows for this kind of functionality.  Am I mistaken?  If I'm not, I'd be
interested in seeing this put together.

Perhaps a bugzilla should be opened to include an SELinux policy for Banshee?
Comment 4 Jason Dexter 2006-04-19 16:37:34 EDT
For me this bug only occurs with an SMP kernel. I have the same symptoms (almost
always crashes) when I'm running an SMP kernel, and Banshee loads with a non-SMP
kernel.
Comment 5 Jason Dexter 2006-04-19 16:38:37 EDT
I should also note that the Banshee project claims this bug is fixed in the new
version (0.10.9-1). In that case, all that needs to be done is get the newest
version in extras.
Comment 6 Christopher Aillon 2006-04-19 16:55:14 EDT
No, this is a problem with avahi-sharp.  In fact, this was working for me UNTIL
I ugpraded to test 0.10.9.  I'll see about getting a new avahi-sharp first and
then push new banshee.
Comment 7 teamwassily 2006-04-19 20:23:03 EDT
I concur.  I used the Banshee spec file, and created an rpm for the 0.10.9
tarball and the problem remains.  Is the problem with avahi-sharp related to the
SMP kernel?  because I too am on an SMP kernel.
Comment 8 Thomas Chung 2006-05-20 19:20:15 EDT
Yup. I'm getting same error message.

$ banshee
Warning: [5/20/2006 4:12:21 PM] (Cannot connect to NetworkManager) - An
available, working network connection will be assumed
Debug: [5/20/2006 4:12:22 PM] (Default player engine) - GStreamer 0.10
Debug: [5/20/2006 4:12:22 PM] (Audio CD Core Initialized) -
Warning: [5/20/2006 4:12:23 PM] (Could not connect to D-Bus) - D-Bus support
will be disabled for this instance: Object reference not set to an instance of
an object

(Banshee:2743): GdkPixbuf-WARNING **: GdkPixbufLoader finalized without calling
gdk_pixbuf_loader_close() - this is not allowed. You must explicitly end the
data stream to the loader before dropping the last reference.
Building initial DAAP database from local library...
Starting DAAP Server
2743: assertion failed "!(connection)->have_connection_lock" file
"dbus-connection.c" line 978 function _dbus_connection_acquire_io_path
/usr/libexec/Banshee: No such file or directory.
Comment 9 Christopher Aillon 2006-10-05 22:29:05 EDT
This was been fixed in an update release of avahi-sharp.

Note You need to log in before you can comment on or make changes to this bug.