Bug 188742 - Servers written in python using m2crypto for ssl fail.
Servers written in python using m2crypto for ssl fail.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: m2crypto (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 14:03 EDT by Jason McBrayer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.15-3.2.fc5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:35:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to Connection.py in m2crypto to fix problem with servers (1.40 KB, patch)
2006-04-12 14:03 EDT, Jason McBrayer
no flags Details | Diff

  None (edit)
Description Jason McBrayer 2006-04-12 14:03:05 EDT
Description of problem:

Servers written in python using m2crypto will fail with the following traceback:

Traceback (most recent call last):
  File "./echod-iterative.py", line 23, in ?
    s.serve_forever()
  File "/usr/lib/python2.4/SocketServer.py", line 201, in serve_forever
    self.handle_request()
  File "/usr/lib/python2.4/site-packages/M2Crypto/SSL/SSLServer.py", line 31, in
handle_request
    request, client_address = self.get_request()
  File "/usr/lib/python2.4/SocketServer.py", line 373, in get_request
    return self.socket.accept()
  File "/usr/lib/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 116,
in accept
    if not check(self.get_peer_cert(), self.addr[0]):
AttributeError: Connection instance has no attribute 'addr'

This includes the sample echod servers included in the doc directory under
demo/ssl/.

Version-Release number of selected component (if applicable):

0.15-3.2

How reproducible:

Always

Steps to Reproduce:
1. cd to /usr/share/docs/m2crypto-0.15/demo/ssl
2. python echod-iterative.py &
3. python echo.py
4. watch traceback

You may have to make a private copy of that directory and edit
echod-iterative.py and echo.py to turn off SSL verification (because the
certificates included in the demo are out of date) in order to get to the traceback.

Actual results:

See traceback above.

Expected results:

echod demo server works with echo client.

Additional info:

This is fixed upstream in svn head and will be fixed in the upcoming 0.16.  This
is the svn checkin that fixes the problem:
http://viewcvs.osafoundation.org/m2crypto/trunk/M2Crypto/SSL/Connection.py?rev=319&view=diff&r1=319&r2=318&p1=trunk/M2Crypto/SSL/Connection.py&p2=/trunk/M2Crypto/SSL/Connection.py

This patch is also attached.
Comment 1 Jason McBrayer 2006-04-12 14:03:05 EDT
Created attachment 127666 [details]
Patch to Connection.py in m2crypto to fix problem with servers
Comment 2 Fedora Update System 2006-04-19 15:20:10 EDT
m2crypto-0.15-3.2.fc5.1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Miloslav Trmač 2006-04-19 16:35:48 EDT
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.