Bug 188770 - (WW) (1400x1050x91,cm752et) mode clock 178.07MHz exceeds DDC maximum 0MHz
(WW) (1400x1050x91,cm752et) mode clock 178.07MHz exceeds DDC maximum 0MHz
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-12 20:28 EDT by Sami Farin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 08:55:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sami Farin 2006-04-12 20:28:36 EDT
Description of problem:
because of some bug or feature, I get only about 50Hz mode of 1400x1050.
I noticed something is wrong when eyes started hurting and screen seemed odd ;-p
with xorg-x11-server-Xorg-1.0.1-9 and xorg-x11-drv-mga-1.2.1.3-1.2 I get the
/same/ DDC0 warnings, but I still get the 91Hz.

Version-Release number of selected component (if applicable):
xorg-x11-drv-mga-1.4.1
xorg-x11-server-Xorg-1.0.99.901-1

How reproducible:
always

Steps to Reproduce:
1. start Xorg
2.
3.
  
Actual results:
getting the lousy mode because DCC botched

Expected results:
getting the configured mode which has worked since 1999...

Additional info:

difference between working and broken Xorg logs


--- Xorg.0.log	2006-04-13 00:31:34.610480565 +0300
+++ Xorg.0.log.DDC0	2006-04-13 00:31:14.622779959 +0300
@@ -4,14 +4,14 @@
 X Protocol Version 11, Revision 0, Release 7.0
 Build Operating System:Linux 2.6.9-22.18.bz155725.ELsmp i686Red Hat, Inc.
 Current Operating System: Linux safari.finland.fbi 2.6.16 #2 Mon Mar 20
22:53:28 EET 2006 i686
-Build Date: 15 March 2006
+Build Date: 09 April 2006
 	Before reporting problems, check http://wiki.x.org
 	to make sure that you have the latest version.
 Module Loader present
 Markers: (--) probed, (**) from config file, (==) default setting,
 	(++) from command line, (!!) notice, (II) informational,
 	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
-(==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 13 00:31:30 2006
+(==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 13 00:14:54 2006
 (==) Using config file: "/etc/X11/xorg.conf"
 (==) ServerLayout "Simple Layout"
 (**) |-->Screen "Screen 1" (0)
@@ -31,30 +31,54 @@
 	Entry deleted from font path.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/webfonts/" does not exist.
 	Entry deleted from font path.
-(**) FontPath set to
"/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/usr/share/X11/fonts/OTF,/usr/share/X11/fonts/TTF,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/cyrillic,/usr/share/X11/fonts/misc,/usr/share/xfce/fonts/,/usr/share/fonts/japanese/TrueType,/usr/share/fonts/japanese/misc,/usr/share/fonts/korean/TrueType,/usr/share/fonts/korean/misc,/usr/share/fonts/chinese/TrueType,/usr/share/fonts/arabic,/usr/share/fonts/bengali,/usr/share/fonts/gujarati,/usr/share/fonts/hebrew,/usr/share/fonts/hindi,/usr/share/fonts/punjabi,/usr/share/fonts/tamil,/usr/share/fonts/KOI8-R/misc,/usr/share/fonts/KOI8-R/75dpi,/usr/share/fonts/KOI8-R/100dpi,/usr/share/fonts/default/Type1/"
+(**) FontPath set to:
+	/usr/share/X11/fonts/100dpi,
+	/usr/share/X11/fonts/75dpi,
+	/usr/share/X11/fonts/OTF,
+	/usr/share/X11/fonts/TTF,
+	/usr/share/X11/fonts/Type1,
+	/usr/share/X11/fonts/cyrillic,
+	/usr/share/X11/fonts/misc,
+	/usr/share/xfce/fonts/,
+	/usr/share/fonts/japanese/TrueType,
+	/usr/share/fonts/japanese/misc,
+	/usr/share/fonts/korean/TrueType,
+	/usr/share/fonts/korean/misc,
+	/usr/share/fonts/chinese/TrueType,
+	/usr/share/fonts/arabic,
+	/usr/share/fonts/bengali,
+	/usr/share/fonts/gujarati,
+	/usr/share/fonts/hebrew,
+	/usr/share/fonts/hindi,
+	/usr/share/fonts/punjabi,
+	/usr/share/fonts/tamil,
+	/usr/share/fonts/KOI8-R/misc,
+	/usr/share/fonts/KOI8-R/75dpi,
+	/usr/share/fonts/KOI8-R/100dpi,
+	/usr/share/fonts/default/Type1/
 (==) RgbPath set to "/usr/share/X11/rgb"
 (==) ModulePath set to "/usr/lib/xorg/modules"
 (**) Option "Xinerama"
 (**) Xinerama: enabled
 (II) Module ABI versions:
-	X.Org ANSI C Emulation: 0.2
-	X.Org Video Driver: 0.8
-	X.Org XInput driver : 0.5
-	X.Org Server Extension : 0.2
-	X.Org Font Renderer : 0.4
+	X.Org ANSI C Emulation: 0.3
+	X.Org Video Driver: 1.0
+	X.Org XInput driver : 0.6
+	X.Org Server Extension : 0.3
+	X.Org Font Renderer : 0.5
 (II) Loader running on linux
 (II) LoadModule: "bitmap"
 (II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
 (II) Module bitmap: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.0.0
 	Module class: X.Org Font Renderer
-	ABI class: X.Org Font Renderer, version 0.4
+	ABI class: X.Org Font Renderer, version 0.5
 (II) Loading font Bitmap
 (II) LoadModule: "pcidata"
 (II) Loading /usr/lib/xorg/modules/libpcidata.so
 (II) Module pcidata: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.0.0
-	ABI class: X.Org Video Driver, version 0.8
+	ABI class: X.Org Video Driver, version 1.0
 (--) using VT number 5
 
 (II) PCI: PCI scan (all values are in hex)
@@ -163,7 +187,7 @@
 (II) Module extmod: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.0.0
 	Module class: X.Org Server Extension
-	ABI class: X.Org Server Extension, version 0.2
+	ABI class: X.Org Server Extension, version 0.3
 (II) Loading extension SHAPE
 (II) Loading extension MIT-SUNDRY-NONSTANDARD
 (II) Loading extension BIG-REQUESTS
@@ -184,28 +208,28 @@
 (II) Module type1: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.0.2
 	Module class: X.Org Font Renderer
-	ABI class: X.Org Font Renderer, version 0.4
+	ABI class: X.Org Font Renderer, version 0.5
 (II) Loading font Type1
 (II) LoadModule: "freetype"
 (II) Loading /usr/lib/xorg/modules/fonts/libfreetype.so
 (II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
 	compiled for 7.0.0, module version = 2.1.0
 	Module class: X.Org Font Renderer
-	ABI class: X.Org Font Renderer, version 0.4
+	ABI class: X.Org Font Renderer, version 0.5
 (II) Loading font FreeType
 (II) LoadModule: "record"
 (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
 (II) Module record: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.13.0
 	Module class: X.Org Server Extension
-	ABI class: X.Org Server Extension, version 0.2
+	ABI class: X.Org Server Extension, version 0.3
 (II) Loading extension RECORD
 (II) LoadModule: "mga"
 (II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
 (II) Module mga: vendor="X.Org Foundation"
-	compiled for 7.0.0, module version = 1.2.1
+	compiled for 7.0.0, module version = 1.4.1
 	Module class: X.Org Video Driver
-	ABI class: X.Org Video Driver, version 0.8
+	ABI class: X.Org Video Driver, version 1.0
 (II) LoadModule: "evdev"
 (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
 (II) Module evdev: vendor="X.Org Foundation"
@@ -219,8 +243,8 @@
 	Module class: X.Org XInput Driver
 	ABI class: X.Org XInput driver, version 0.5
 (II) MGA: driver for Matrox chipsets: mga2064w, mga1064sg, mga2164w,
-	mga2164w AGP, mgag100, mgag100 PCI, mgag200, mgag200 PCI, mgag400,
-	mgag550
+	mga2164w AGP, mgag100, mgag100 PCI, mgag200, mgag200 PCI,
+	mgag200 SE A PCI, mgag200 SE B PCI, mgag400, mgag550
 (II) Primary Device is: PCI 01:00:0
 (--) Assigning device section with no busID to primary device
 (--) Chipset mgag200 found
@@ -277,7 +301,7 @@
 (II) Loading /usr/lib/xorg/modules/libvgahw.so
 (II) Module vgahw: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 0.1.0
-	ABI class: X.Org Video Driver, version 0.8
+	ABI class: X.Org Video Driver, version 1.0
 (--) MGA(0): Chipset: "mgag200"
 (**) MGA(0): Depth 24, (--) framebuffer bpp 32
 (==) MGA(0): RGB weight 888
@@ -288,24 +312,26 @@
 (--) MGA(0): Pseudo-DMA transfer window at 0xD5000000
 (==) MGA(0): BIOS at 0xC0000
 (--) MGA(0): Video BIOS info block at offset 0x07540
+(==) MGA(0): Write-combining range (0xd8000000,0x800000)
 (--) MGA(0): VideoRAM: 8192 kByte
 (II) Loading sub module "ddc"
 (II) LoadModule: "ddc"
 (II) Loading /usr/lib/xorg/modules/libddc.so
 (II) Module ddc: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.0.0
-	ABI class: X.Org Video Driver, version 0.8
+	ABI class: X.Org Video Driver, version 1.0
 (II) Loading sub module "i2c"
 (II) LoadModule: "i2c"
 (II) Loading /usr/lib/xorg/modules/libi2c.so
 (II) Module i2c: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.2.0
-	ABI class: X.Org Video Driver, version 0.8
+	ABI class: X.Org Video Driver, version 1.0
+(==) MGA(0): Write-combining range (0xd8000000,0x800000)
 (II) MGA(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
 (II) MGA(0): I2C bus "DDC P1" initialized.
 (II) MGA(0): I2C device "DDC P1:ddc2" registered at address 0xA0.
 (II) MGA(0): I2C device "DDC P1:ddc2" removed.
-(II) MGA(0): I2C Monitor info: 0x83f0040
+(II) MGA(0): I2C Monitor info: 0x953edc0
 (II) MGA(0): Manufacturer: HTC  Model: ac15  Serial#: 16843009
 (II) MGA(0): Year: 1998  Week: 0
 (II) MGA(0): EDID Version: 1.1
@@ -573,19 +599,19 @@
 (II) Loading /usr/lib/xorg/modules/libfb.so
 (II) Module fb: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.0.0
-	ABI class: X.Org ANSI C Emulation, version 0.2
+	ABI class: X.Org ANSI C Emulation, version 0.3
 (II) Loading sub module "xaa"
 (II) LoadModule: "xaa"
 (II) Loading /usr/lib/xorg/modules/libxaa.so
 (II) Module xaa: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 1.2.0
-	ABI class: X.Org Video Driver, version 0.8
+	ABI class: X.Org Video Driver, version 1.0
 (II) Loading sub module "ramdac"
 (II) LoadModule: "ramdac"
 (II) Loading /usr/lib/xorg/modules/libramdac.so
 (II) Module ramdac: vendor="X.Org Foundation"
 	compiled for 7.0.0, module version = 0.1.0
-	ABI class: X.Org Video Driver, version 0.8
+	ABI class: X.Org Video Driver, version 1.0
 (--) Depth 24 pixmap format is 32 bpp
 (II) do I need RAC?  No, I don't.
 (II) resource ranges after preInit:
@@ -617,6 +643,7 @@
 	[25] -1	0	0x0000f000 - 0x0000f00f (0x10) IX[B]
 	[26] 0	0	0xd40103b0 - 0xd40103bb (0xc) IS[B](OprU)
 	[27] 0	0	0xd40103c0 - 0xd40103df (0x20) IS[B](OprU)
+(==) MGA(0): Write-combining range (0xd8000000,0x800000)
 (II) MGA(0): vgaHWGetIOBase: hwp->IOBase is 0x03d0, hwp->PIOOffset is 0x0000
 (--) MGA(0): 64 DWORD fifo
 (==) MGA(0): Default visual is TrueColor
@@ -648,7 +675,6 @@
 (II) Initializing built-in extension XInputExtension
 (II) Initializing built-in extension XTEST
 (II) Initializing built-in extension XKEYBOARD
-(II) Initializing built-in extension LBX
 (II) Initializing built-in extension XC-APPGROUP
 (II) Initializing built-in extension SECURITY
 (II) Initializing built-in extension XINERAMA
@@ -682,3 +708,14 @@
 (**) Keyboard1: CustomKeycodes disabled
 (II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
 (II) XINPUT: Adding extended input device "IntelliMouse" (type: MOUSE)
+    xkb_keycodes             { include "xfree86+aliases(qwerty)" };
+    xkb_types                { include "complete" };
+    xkb_compatibility        { include "complete" };
+    xkb_symbols              { include "pc(pc104)+fi+level3(ralt_switch)" };
+    xkb_geometry             { include "pc(pc104)" };
+    xkb_keycodes             { include "xfree86+aliases(qwerty)" };
+    xkb_types                { include "complete" };
+    xkb_compatibility        { include "complete" };
+    xkb_symbols              { include "pc(pc104)+fi+level3(ralt_switch)" };
+    xkb_geometry             { include "pc(pc104)" };
+(II) IntelliMouse: Close
Comment 1 Mike A. Harris 2006-05-23 08:55:15 EDT
If this issue turns out to still be reproduceable in the latest
rawhide builds, please file a bug report in the X.Org bugzilla
located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.
Comment 2 Sami Farin 2006-05-23 09:15:33 EDT
I tried the latest rawhide build...

Looks like they like to fix this bug only after 7.2 is released.
https://bugs.freedesktop.org/show_bug.cgi?id=5184

But I can try some patches if you give me some.
Comment 3 Mike A. Harris 2006-05-23 09:23:11 EDT
Thanks for the upstream bug URL.  Once there is a fix available from X.Org
upstream, we will review it and consider it for inclusion in future Fedora
Core updates.
Comment 4 Sami Farin 2006-08-06 11:41:09 EDT
I tried 1.1.1-15, which has patches with adverts such as
"Various touchups to the EDID auto-injection to make things work"
and
"Allow HorizSync and VertRefresh to be overridden independently"

Every thing tells me I should be getting 160 Hz / 100 kHz, but
in reality I get at max 60 kHz / 55 Hz.  Why?  What's the idea?

(II) MGA(0): Ranges: V min: 50  V max: 160 Hz, H min: 31  H max: 100 kHz,
(II) MGA(0): Monitor name: CM752
...
(II) MGA(0): Using hsync ranges from config file
(II) MGA(0): Using vrefresh ranges from config file
...
(==) MGA(0): Min pixel clock is 12 MHz
(--) MGA(0): Max pixel clock is 250 MHz
(II) MGA(0): cm752et: Using hsync range of 31.00-100.00 kHz
(II) MGA(0): cm752et: Using vrefresh range of 50.00-160.00 Hz
(II) MGA(0): Clock range:  12.00 to 250.00 MHz
...
(--) MGA(0): Virtual size is 1400x1050 (pitch 1408)
(**) MGA(0): *Mode "1400x1050x91": 178.1 MHz, 99.4 kHz, 91.0 Hz
(II) MGA(0): Modeline "1400x1050x91"  178.07  1400 1456 1512 1792  1050 1052
1054 1092
(**) MGA(0): *Mode "768x576x150d": 92.0 MHz, 92.7 kHz, 75.0 Hz (D)
(II) MGA(0): Modeline "768x576x150d"   91.95  768 800 832 992  576 578 580 618
doublescan


Note You need to log in before you can comment on or make changes to this bug.