Bug 18883 - Python module 'socketmodule.so' not working with more recent libc
Summary: Python module 'socketmodule.so' not working with more recent libc
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: python (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-11 13:32 UTC by cjenkins
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-11 13:32:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description cjenkins 2000-10-11 13:32:10 UTC
The following error results when trying to 'import socket' on a system
running glibc-2.1.3:
"ImportError: /usr/lib/python1.5/lib-dynload/socketmodule.so: symbol
gethostbyaddr_r, version GLIBC_2.1.2 not defined in file libc.so.6 with
link time reference "

The reference appears to be to the following symbol:
gethostbyaddr_r@@GLIBC_2.1.2 , which should be ok with a more recent
version of libc but is not. There are also other modules with similar
dependencies. 

By recompiling the python1.5.2-28 SRPM the only depencencies I now see are
based on glibc-2.0 or 2.1, no sub-minor version number.

Comment 1 Matt Wilson 2001-01-27 02:06:19 UTC
works in recent rawhides.



Note You need to log in before you can comment on or make changes to this bug.