Bug 1888466 - [ROKS] no matches for kind \"VolumeSnapshotClass\" in version \"snapshot.storage.k8s.io/v1beta1\"" For IBM Cloud deployment
Summary: [ROKS] no matches for kind \"VolumeSnapshotClass\" in version \"snapshot.stor...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenShift Container Storage
Classification: Red Hat
Component: ocs-operator
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Jose A. Rivera
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-14 22:12 UTC by Petr Balogh
Modified: 2020-10-21 16:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-21 16:25:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Balogh 2020-10-14 22:12:11 UTC
Description of problem (please be detailed as possible and provide log
snippests):
When deploying the OCS 4.6 on IBM Cloud ROKS on OCP 4.5 when creating storageCluster CR I see that nothing happen and in ocs-operator log I see those errors:

{"level":"error","ts":"2020-10-14T21:19:01.380Z","logger":"controller_storagecluster","msg":"failed to 'Get' SnapshotClass \"ocs-storagecluster-rbdplugin-snapclass\"","Request.Namespace":"openshift-storage","Request.Name":"ocs-storagecluster","error":"no matches for kind \"VolumeSnapshotClass\" in version \"snapshot.storage.k8s.io/v1beta1\"","stacktrace":"github.com/go-logr/zapr.(*zapLogger).Error\n\t/remote-source/app/vendor/github.com/go-logr/zapr/zapr.go:128\ngithub.com/openshift/ocs-operator/pkg/controller/storagecluster.(*ReconcileStorageCluster).createSnapshotClasses\n\t/remote-source/app/pkg/controller/storagecluster/volumesnapshotterclasses.go:73\ngithub.com/openshift/ocs-operator/pkg/controller/storagecluster.(*ReconcileStorageCluster).ensureSnapshotClasses\n\t/remote-source/app/pkg/controller/storagecluster/volumesnapshotterclasses.go:102\ngithub.com/openshift/ocs-operator/pkg/controller/storagecluster.(*ReconcileStorageCluster).Reconcile\n\t/remote-source/app/pkg/controller/storagecluster/reconcile.go:231\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).reconcileHandler\n\t/remote-source/app/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:256\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).processNextWorkItem\n\t/remote-source/app/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:232\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).worker\n\t/remote-source/app/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:211\nk8s.io/apimachinery/pkg/util/wait.JitterUntil.func1\n\t/remote-source/app/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:152\nk8s.io/apimachinery/pkg/util/wait.JitterUntil\n\t/remote-source/app/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:153\nk8s.io/apimachinery/pkg/util/wait.Until\n\t/remote-source/app/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:88"}
{"level":"error","ts":"2020-10-14T21:19:01.435Z","logger":"controller-runtime.controller","msg":"Reconciler error","controller":"storagecluster-controller","request":"openshift-storage/ocs-storagecluster","error":"no matches for kind \"VolumeSnapshotClass\" in version \"snapshot.storage.k8s.io/v1beta1\"","stacktrace":"github.com/go-logr/zapr.(*zapLogger).Error\n\t/remote-source/app/vendor/github.com/go-logr/zapr/zapr.go:128\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).reconcileHandler\n\t/remote-source/app/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:258\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).processNextWorkItem\n\t/remote-source/app/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:232\nsigs.k8s.io/controller-runtime/pkg/internal/controller.(*Controller).worker\n\t/remote-source/app/vendor/sigs.k8s.io/controller-runtime/pkg/internal/controller/controller.go:211\nk8s.io/apimachinery/pkg/util/wait.JitterUntil.func1\n\t/remote-source/app/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:152\nk8s.io/apimachinery/pkg/util/wait.JitterUntil\n\t/remote-source/app/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:153\nk8s.io/apimachinery/pkg/util/wait.Until\n\t/remote-source/app/vendor/k8s.io/apimachinery/pkg/util/wait/wait.go:88"}
{"level":"info","ts":"2020-10-14T21:19:02.436Z","logger":"controller_storagecluster","msg":"Reconciling StorageCluster","Request.Namespace":"openshift-storage","Request.Name":"ocs-storagecluster"}


Version of all relevant components (if applicable):
OCP Server Version: 4.5.13
4.6.0-131.ci

Does this issue impact your ability to continue to work with the product
(please explain in detail what is the user impact)?
Yes, cannot deploy on ROKS cluster


Is there any workaround available to the best of your knowledge?
No


Rate from 1 - 5 the complexity of the scenario you performed that caused this
bug (1 - very simple, 5 - very complex)?
1


Can this issue reproducible?
Yes


Can this issue reproduce from the UI?
Haven't tried


If this is a regression, please provide more details to justify this:


Steps to Reproduce:
1.
Instell OCS on ROKS OCP 4.5 cluster
2. After creating storageCluster CR nothing happens
3. In the ocs-operator logs I see the error mentioned above


Actual results:
No deployment success

Expected results:
After create storageCluster see starting spinning up all needed pods


Additional info:

Comment 4 Mudit Agarwal 2020-10-15 03:39:23 UTC
Madhu, PTAL

Comment 8 Mudit Agarwal 2020-10-15 08:52:01 UTC
Petr, it is more of a configuration issue specific to this platform. We have a workaround also, can we remove the blocker flag?

Comment 9 Petr Balogh 2020-10-15 10:34:05 UTC
Hey Mudit,

maybe we can do the clone of this BZ to the OCP and keep this as a tracker for OCS?  We need to discuss with IBM guys and confirm with them, and maybe Eran if this is the blocker for them for 4.6 release.

Meanwhile I am running OCP 4.5 deployment job with OCS 4.6 here:
https://ocs4-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/qe-deploy-ocs-cluster/13544/

To confirm that we don't have the same issue in other platform as well.

So at this stage I am not the one who can decide about removing blocker flag as of now.

Comment 10 Sahina Bose 2020-10-15 11:18:50 UTC
Akash, will these configurations mentioned in Comment 7 be taken care of as part of ROKS installer?

Comment 11 akgunjal@in.ibm.com 2020-10-16 07:02:37 UTC
Sahina, Petr: I have raised an internal ticket within IBM Cloud to created then 3 CRDs of external-snapshotter in ROKS 4.5 version onwards. Will keep posted on the updates from that ticket.

Comment 14 Jose A. Rivera 2020-10-20 14:36:34 UTC
Since this is just a tracker and there's nothing for us to do in OCS 4.6, moving this to OCS 4.7.

Comment 16 Petr Balogh 2020-10-21 13:58:48 UTC
After the discussion with IBM cloud guys we can close this as not a bug as this will be handled in IBM Cloud OCP deployment automation and it's not OCS bug.


Note You need to log in before you can comment on or make changes to this bug.