Bug 1888838 - Installer fails due to yum-utils not being whitelisted on foreman-protector
Summary: Installer fails due to yum-utils not being whitelisted on foreman-protector
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Installer
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Devendra Singh
URL:
Whiteboard:
: 1888837 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-15 22:00 UTC by Taft Sanders
Modified: 2020-10-23 07:05 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-19 14:48:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 30869 0 Normal Closed Add yum-utils in foreman-maintain.whitelist. 2020-11-17 10:39:03 UTC
Red Hat Knowledge Base (Solution) 5493671 0 None None None 2020-10-15 22:12:29 UTC

Description Taft Sanders 2020-10-15 22:00:44 UTC
Description of problem:
Installer fails due to yum-utils not being whitelisted on foreman-protector

Version-Release number of selected component (if applicable):
rubygem-foreman_maintain-0.5.5-1.el7sat.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Install Satellite
2. Update Satellite
3.

Actual results:
D, [2020-10-15 16:17:26-0400 #13333] DEBUG -- : Running command rpm -q 'yum-utils' --queryformat="%{VERSION}" with stdin nil
D, [2020-10-15 16:17:26-0400 #13333] DEBUG -- : output of the command:
 package yum-utils is not installed
I, [2020-10-15 16:17:27-0400 #13333]  INFO -- : === Scenario 'preparation steps required to run the next scenarios' started ===
I, [2020-10-15 16:17:27-0400 #13333]  INFO -- : --- Execution step 'Install packages' [packages-install] started ---
D, [2020-10-15 16:17:27-0400 #13333] DEBUG -- : Running command yum install yum-utils with stdin nil
D, [2020-10-15 16:17:36-0400 #13333] DEBUG -- : output of the command:
 Script started on Thu 15 Oct 2020 04:17:27 PM EDT
Loaded plugins: foreman-protector, product-id, search-disabled-repos, subscription-manager

WARNING: Excluding 12563 packages due to foreman-protector. 
Use foreman-maintain packages install/update <package> 
to safely install packages without restrictions.
Use foreman-maintain upgrade run for full upgrade.

No package yum-utils available.
Error: Nothing to do

E, [2020-10-15 16:17:36-0400 #13333] ERROR -- : Failed executing yum install yum-utils, exit status 1 (ForemanMaintain::Error::ExecutionError)
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/utils/command_runner.rb:54:in `execution_error'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/concerns/system_helpers.rb:63:in `execute!'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/package_manager/yum.rb:105:in `yum_action'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/package_manager/yum.rb:49:in `install'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/concerns/system_helpers.rb:103:in `packages_action'
/usr/share/gems/gems/foreman_maintain-0.5.5/definitions/procedures/packages/install.rb:14:in `run'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/executable.rb:139:in `__run__'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner/execution.rb:83:in `block (2 levels) in run'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner/execution.rb:107:in `capture_errors'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner/execution.rb:82:in `block in run'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner/execution.rb:101:in `with_metadata_calculation'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner/execution.rb:81:in `run'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:122:in `run_step'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:111:in `run_steps'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:104:in `execute_scenario_steps'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:51:in `run_scenario'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:99:in `block in execute_scenario_steps'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:99:in `each'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:99:in `execute_scenario_steps'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/runner.rb:51:in `run_scenario'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/upgrade_runner.rb:138:in `block in run_phase'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/upgrade_runner.rb:185:in `with_non_empty_scenario'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/upgrade_runner.rb:134:in `run_phase'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/upgrade_runner.rb:82:in `block in run'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/upgrade_runner.rb:77:in `each'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/upgrade_runner.rb:77:in `run'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/cli/upgrade_command.rb:80:in `execute'
/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:63:in `run'
/usr/share/gems/gems/clamp-1.1.2/lib/clamp/subcommand/execution.rb:11:in `execute'
/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:63:in `run'
/usr/share/gems/gems/clamp-1.1.2/lib/clamp/subcommand/execution.rb:11:in `execute'
/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:63:in `run'
/usr/share/gems/gems/foreman_maintain-0.5.5/lib/foreman_maintain/cli.rb:32:in `run'
/usr/share/gems/gems/clamp-1.1.2/lib/clamp/command.rb:132:in `run'
/usr/share/gems/gems/foreman_maintain-0.5.5/bin/foreman-maintain:15:in `<top (required)>'
/usr/bin/foreman-maintain:23:in `load'
/usr/bin/foreman-maintain:23:in `<main>'
I, [2020-10-15 16:17:36-0400 #13333]  INFO -- : --- Execution step 'Install packages' finished ---
I, [2020-10-15 16:17:36-0400 #13333]  INFO -- : === Scenario 'preparation steps required to run the next scenarios' finished ===


Expected results:
no failure

Additional info:
https://projects.theforeman.org/issues/30869

Comment 1 Brad Buckingham 2020-10-19 14:48:52 UTC
The fix for this has been merged upstream and will be included in foreman-maintain with the release of Satellite 6.8.

For this reason, I am going to move this to CLOSED:NEXTRELEASE.  If there are any concerns, please feel free to re-open with appropriate details.

Comment 2 Taft Sanders 2020-10-23 07:05:03 UTC
*** Bug 1888837 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.