Bug 188891 - kernel spec file 2.6.16 -1.2128 no general disable of build PAE
kernel spec file 2.6.16 -1.2128 no general disable of build PAE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 04:49 EDT by Thomas Steudten
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 17:51:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Steudten 2006-04-13 04:49:21 EDT
Description of problem:

In the header section of the kernel spec file, there're some values to enable or
disable settings, like %define buildpae 0.
But this are not override settings, but predefined values. Later this value will
be override by %ifarch i686
%define buildpae 1
%endif

But if someone won't build the PAE kernel, there's no global setting to do this
simply in the header section. The first look to this section shows ok, it is
disabled, but then it is enabled again. Please find a better way for this.

Version-Release number of selected component (if applicable):
kernel spec file 2.6.16 -1.2128 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2006-04-18 17:51:34 EDT
they were never intended as override settings.
Comment 2 Thomas Steudten 2006-04-20 05:54:11 EDT
(In reply to comment #1)
> they were never intended as override settings.
> 

I know, but the enable xenbuild is used like this, why not this setting? Setting
a flag deep in the code is not the best way.

Note You need to log in before you can comment on or make changes to this bug.