Bug 188898 - test not builtin to tcsh
test not builtin to tcsh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: coreutils (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 192399 (view as bug list)
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-04-13 06:20 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0213
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 18:52:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-04-13 06:20:11 EDT
+++ This bug was initially created as a clone of Bug #188897 +++

coreutils-5.2.1-31.2 contains the colorls.csh profile script
(/etc/profile.d/colorls.csh) which uses "test".

However, test is not builtin to C shells (as opposed to bash) so a funky $PATH
could find a "test" binary somewhere else.

Better be safe and hard-code /usr/bin/test instead

-- Additional comment from bnocera@redhat.com on 2006-04-13 06:18 EST --
Created an attachment (id=127701)
coreutils-no-builtin-test-csh.patch
Comment 1 Tim Waugh 2006-04-18 08:34:20 EDT
Better fix already in rawhide.
Comment 2 RHEL Product and Program Management 2006-08-18 12:16:08 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Tim Waugh 2006-09-11 12:43:12 EDT
*** Bug 192399 has been marked as a duplicate of this bug. ***
Comment 11 Red Hat Bugzilla 2007-05-01 18:52:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0213.html

Note You need to log in before you can comment on or make changes to this bug.