This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 188904 - RFE: The current caption.sty is outdated
RFE: The current caption.sty is outdated
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
http://groups.google.com/group/comp.t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 09:21 EDT by Marc Schwartz
Modified: 2013-07-02 19:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 04:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Schwartz 2006-04-13 09:21:44 EDT
Description of problem:

I became aware this morning, via an exchange on comp.text.tex, that the current
version of the FC4 caption style package is outdated.

The thread in question is available here:

http://groups.google.com/group/comp.text.tex/browse_thread/thread/68f193dc57baf9c8/1faf44b0ee522a0c

It is currently dated July 18, 2004. The most recent version on CTAN is January
21, 2006 and there are apparently other interim updates since 2004.

The newer version(s) apparently handle certain situations (such as forcing
multiline captions) without errors.


Version-Release number of selected component (if applicable):

tetex-latex-3.0-9.FC4


How reproducible:

Always


Steps to Reproduce:
1. Run latex or pdflatex on the source file in the usenet thread above
2. Errors relating to the use of "\\" to force line breaks in the caption are
reported (for line 17 in the source file, which is the caption code). Removing
the "\\" removes the error messages.

  
Actual results:

Errors are reported as described above.


Expected results:

According to other participants in the referenced thread, the newer versions do
not report these errors, suggesting better handling of at least this situation
and perhaps others, including perhaps other functional updates.


Additional info:

I'm not sure what process is in place to review and update TeX styles in the FC
packages, but presumably if this style is outdated, there may be others worthy
of review?

Thanks.
Comment 1 Marc Schwartz 2006-04-13 11:30:10 EDT
Just as a quick follow up, the booktabs.sty is also outdated. The version in FC4
is dated April 7, 2003, whilst the current version on CTAN is dated April 14, 2005.
Comment 2 Jindrich Novy 2006-04-20 10:43:28 EDT
The caption style is now updated in rawhide. Maybe there are many styles that
are outdated, but it's quite impossible to keep them all to date. Maybe we
should push upstream developers to do releases more frequently.
Comment 3 Marc Schwartz 2006-04-20 11:15:32 EDT
Jindrich, thanks for the follow up.

To your query, that would be great if reasonable. As you note, there are many
packages within the TeTeX distribution. I don't know what resources Thomas Esser
may or may not have to address this point.

From reviewing the repo at:

  ftp://tug.ctan.org/tex-archive/systems/unix/teTeX/current/distrib/

it would be appear that it has been over a year since the last official 3.0
release, with no indications of incremental updates from what I can see.

The history with v2.x seems to have been two early and rapid bug fix releases,
but no incremental feature updates.

Thanks again.
Comment 4 Fedora Update System 2006-04-27 18:02:55 EDT
tetex-3.0-19.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Fedora Update System 2006-05-26 10:10:49 EDT
tetex-3.0-10.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 6 Fedora Update System 2006-06-07 19:37:41 EDT
tetex-3.0-10.FC4 has been pushed for fc4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.