Bug 18892 - add support for the 'plusb' network device
add support for the 'plusb' network device
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 10:28 EDT by eric.ayers
Modified: 2014-03-16 22:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-11 10:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description eric.ayers 2000-10-11 10:28:03 EDT
I've got a file to add to the initscripts package that allows the USB
host-host cable
based on the prolific chip to work properly.    If you want to test this
device for yourself,
you can order one of these cables from 'usbdevices' or  buy a 'siig' cable
(I got mine from buy.com)  Notably, the belkin cable does NOT use this
chip, and that' s the one I found most
commonly in the retail shops around town.

Here's my example configuration:

[cgi@dru1b cgi]$ cat /etc/sysconfig/network-scripts/ifcfg-plip0 
#
# *** CGI *** Private LAN for heartbeat
# Installed from kickstart configuration
#
DEVICE=plip0
BOOTPROTO=static
BROADCAST=10.0.1.255
NETMASK=255.255.255.0
NETWORK=10.0.1.0
ONBOOT=yes
IPADDR=10.0.1.1
REMIP=10.0.1.2


The broadcast address isn't essential, but it helps me out because I'm
trying 
to use this device with the linux-ha 'heartbeat' package.  OK, here's the
file itself.

#!/bin/sh
#
# /etc/sysconfig/network-scripts/ifup-plusb
#
# the plusb network driver is a USB host-host cable based on the Prolific
chip.
# It works a lot like the plip driver.  
#
# To get the plusb module to load automatically at boot, you will need to
add
# the following lines to /etc/conf.modules, based on what type of USB host
# controller you have on your system:
#
# alias plusb0 plusb
# below plusb usb-uhci
#   *or*
# below plusb usb-ohci
#
PATH=/sbin:/usr/sbin:/bin:/usr/bin

cd /etc/sysconfig/network-scripts
. network-functions

CONFIG=$1
source_config

if [ "foo$2" = "fooboot" -a "${ONBOOT}" = "no" ]
then
	exit
fi

if [ ${BROADCAST} != ""  ]  ; then
    ifconfig ${DEVICE} ${IPADDR} pointopoint ${REMIP} netmask ${NETMASK}
broadcast ${BROADCAST}
else
    ifconfig ${DEVICE} ${IPADDR} pointopoint ${REMIP} netmask ${NETMASK} 
fi

. /etc/sysconfig/network

if [ "${GATEWAY}" != "" ]; then
	if [ "${GATEWAYDEV}" = "" -o "${GATEWAYDEV}" = "${DEVICE}" ]; then
		# set up default gateway
		route add default gw ${GATEWAY}
	fi
fi

/etc/sysconfig/network-scripts/ifup-post $1
Comment 1 Bill Nottingham 2001-01-29 19:08:17 EST
Will be in initscripts-5.60-1; thanks for the patch!

Note You need to log in before you can comment on or make changes to this bug.