Bug 1889291 - Incorrect ptp bundle image attached to stage 4.6 iib image
Summary: Incorrect ptp bundle image attached to stage 4.6 iib image
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.7.0
Assignee: zenghui.shi
QA Contact: huirwang
URL:
Whiteboard:
Depends On:
Blocks: 1889704
TreeView+ depends on / blocked
 
Reported: 2020-10-19 09:55 UTC by Sabina Aledort
Modified: 2020-10-21 10:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1889704 (view as bug list)
Environment:
Last Closed: 2020-10-21 10:42:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sabina Aledort 2020-10-19 09:55:33 UTC
Description of problem:
When getting the manifests from this 4.6 stage image: registry-proxy.engineering.redhat.com/rh-osbs/iib-pub-pending:v4.6, the ptp bundle image in the mapping.txt file seems to be incorrect. 
The attached ptp bundle image is:
registry.stage.redhat.io/openshift4/ose-ptp-operator-metadata@sha256:fe5ea4347ecdefb39f85be9fcd61cc8708d291580a388b41a742a492a12b5f1f
When pulling this image i get an error that the image doesn't exist. I changed "metadata" to "bundle" with the same sha, and was able to pull the image successfully. 
The image i pulled is: 
registry.stage.redhat.io/openshift4/ose-ptp-operator-bundle@sha256:fe5ea4347ecdefb39f85be9fcd61cc8708d291580a388b41a742a492a12b5f1f
In addition, the bundle image in brew is "registry-proxy.engineering.redhat.com/rh-osbs/openshift-ose-ptp-operator-bundle@sha256..." and not "registry-proxy.engineering.redhat.com/rh-osbs/openshift-ose-ptp-operator-metadata@sha256...".
For example: https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1347993

How reproducible:
To get the manifests and the mapping.txt file, run:
'oc adm catalog mirror registry-proxy.engineering.redhat.com/rh-osbs/iib-pub-pending:v4.6 $LOCAL_REG -a $PULL_SECRET --manifests-only --to-manifests=$OPRERATORS_MANIFESTS_DIR'

Actual results:
registry.stage.redhat.io/openshift4/ose-ptp-operator-metadata@sha256:fe5ea4347ecdefb39f85be9fcd61cc8708d291580a388b41a742a492a12b5f1f

Expected results:
registry.stage.redhat.io/openshift4/ose-ptp-operator-bundle@sha256:fe5ea4347ecdefb39f85be9fcd61cc8708d291580a388b41a742a492a12b5f1f

Additional info:
We are able to deploy sriov operator successfully using the iib stage image. 
The attached sriov operator bundle image is:
registry.stage.redhat.io/openshift4/ose-sriov-network-operator-bundle@sha256:ee1b3e57caf643e404082d4d575c2aefc9be2b5cfa8331b30e0d4850f6abf515
The same as in brew, for example here:
https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=1347996

Comment 7 zenghui.shi 2020-10-21 10:42:05 UTC
closing per comment #6


Note You need to log in before you can comment on or make changes to this bug.