Bug 1889471 - i'm unable to install the container-tools:1.0
Summary: i'm unable to install the container-tools:1.0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: microdnf
Version: 8.2
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: rc
: 8.0
Assignee: Packaging Maintenance Team
QA Contact: swm-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 18:05 UTC by pbajjuri
Modified: 2020-11-03 22:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-26 15:00:21 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description pbajjuri 2020-10-19 18:05:10 UTC
Description of problem:

unable to install the contanier tools:rhel8


Version-Release number of selected component (if applicable):


How reproducible:

sudo dnf install -y @container-tools
Updating Subscription Management repositories.
This system is receiving updates from Red Hat Satellite or Spacewalk server.
Repository google-chrome is listed more than once in the configuration
Last metadata expiration check: 0:00:14 ago on Tue 20 Oct 2020 01:41:19 AM +08.
Module or Group 'container-tools' is not available.
Error: Nothing to do.



Actual results:

install container tolls 

Expected results:


Additional info:

i want to install podman on system. container tools not available and my system is under repair - i have taken loaner laptop

Comment 1 pbajjuri 2020-10-19 18:54:55 UTC
sudo dnf module install container-tools -y

unable install the contanier- tools module

Comment 2 Marek Blaha 2020-10-26 12:43:49 UTC
This is strange. container-tools is a module available in AppStream repository:

# dnf module list container-tools
Updating Subscription Management repositories.
Name                        Stream                Profiles              Summary                                                        
container-tools             rhel8 [d]             common [d]            Common tools and dependencies for container runtimes           
container-tools             1.0                   common [d]            Common tools and dependencies for container runtimes           
container-tools             2.0                   common [d]            Common tools and dependencies for container runtimes

Given the module has both default stream and default profile, your command should be working:

# dnf install @container-tools
Updating Subscription Management repositories.
Last metadata expiration check: 0:06:44 ago on Mon Oct 26 08:31:57 2020.
Dependencies resolved.
=======================================================================================================================================
 Package                        Arch     Version                                              Repository                          Size
=======================================================================================================================================
Installing group/module packages:
 buildah                        x86_64   1.14.9-1.module+el8.2.1+6689+748e6520                rhel-8-for-x86_64-appstream-rpms   9.0 M
 cockpit-podman                 noarch   17-1.module+el8.2.1+6636+bf4db4ab                    rhel-8-for-x86_64-appstream-rpms   1.1 M
 conmon                         x86_64   2:2.0.17-1.module+el8.2.1+6771+3533eb4c              rhel-8-for-x86_64-appstream-rpms    39 k
 container-selinux              noarch   2:2.135.0-1.module+el8.2.1+6849+893e4f4a             rhel-8-for-x86_64-appstream-rpms    49 k
 containernetworking-plugins    x86_64   0.8.6-1.module+el8.2.1+6626+598993b4                 rhel-8-for-x86_64-appstream-rpms    20 M
 criu                           x86_64   3.14-2.module+el8.2.1+6750+e53a300c                  rhel-8-for-x86_64-appstream-rpms   500 k
 fuse-overlayfs                 x86_64   1.0.0-2.module+el8.2.1+6465+1a51e8b6                 rhel-8-for-x86_64-appstream-rpms    60 k
 libslirp                       x86_64   4.3.0-3.module+el8.2.1+6816+bedf4f91                 rhel-8-for-x86_64-appstream-rpms    68 k
 podman                         x86_64   1.9.3-2.module+el8.2.1+6867+366c07d6                 rhel-8-for-x86_64-appstream-rpms    13 M
 python-podman-api              noarch   1.2.0-0.2.gitd0a45fe.module+el8.2.1+6465+1a51e8b6    rhel-8-for-x86_64-appstream-rpms    43 k
 runc                           x86_64   1.0.0-66.rc10.module+el8.2.1+6465+1a51e8b6           rhel-8-for-x86_64-appstream-rpms   2.7 M
 skopeo                         x86_64   1:1.0.0-1.module+el8.2.1+6676+604e1b26               rhel-8-for-x86_64-appstream-rpms   6.6 M
 slirp4netns                    x86_64   1.0.1-1.module+el8.2.1+6595+03641d72                 rhel-8-for-x86_64-appstream-rpms    45 k
 toolbox                        noarch   0.0.7-1.module+el8.2.1+6465+1a51e8b6                 rhel-8-for-x86_64-appstream-rpms    16 k
 udica                          noarch   0.2.1-2.module+el8.2.1+6465+1a51e8b6                 rhel-8-for-x86_64-appstream-rpms    48 k
Installing dependencies:
 PackageKit-glib                x86_64   1.1.12-4.el8                                         rhel-8-for-x86_64-appstream-rpms   140 k
 cairo                          x86_64   1.15.12-3.el8                                        rhel-8-for-x86_64-appstream-rpms   721 k
 cairo-gobject                  x86_64   1.15.12-3.el8                                        rhel-8-for-x86_64-appstream-rpms    33 k
 cockpit-bridge                 x86_64   211.3-1.el8                                          rhel-8-for-x86_64-baseos-rpms      618 k
 cockpit-system                 noarch   211.3-1.el8                                          rhel-8-for-x86_64-baseos-rpms      2.3 M
 containers-common              x86_64   1:1.0.0-1.module+el8.2.1+6676+604e1b26               rhel-8-for-x86_64-appstream-rpms    52 k
 fontconfig                     x86_64   2.13.1-3.el8                                         rhel-8-for-x86_64-baseos-rpms      275 k
 fontpackages-filesystem        noarch   1.44-22.el8                                          rhel-8-for-x86_64-baseos-rpms       16 k
 fuse3-libs                     x86_64   3.2.1-12.el8                                         rhel-8-for-x86_64-baseos-rpms       94 k
 gdk-pixbuf2                    x86_64   2.36.12-5.el8                                        rhel-8-for-x86_64-baseos-rpms      467 k
 glib-networking                x86_64   2.56.1-1.1.el8                                       rhel-8-for-x86_64-baseos-rpms      155 k
 gsettings-desktop-schemas      x86_64   3.32.0-4.el8                                         rhel-8-for-x86_64-baseos-rpms      633 k
 libX11                         x86_64   1.6.8-3.el8                                          rhel-8-for-x86_64-appstream-rpms   611 k
 libX11-common                  noarch   1.6.8-3.el8                                          rhel-8-for-x86_64-appstream-rpms   158 k
 libXau                         x86_64   1.0.8-13.el8                                         rhel-8-for-x86_64-appstream-rpms    36 k
 libXext                        x86_64   1.3.3-9.el8                                          rhel-8-for-x86_64-appstream-rpms    45 k
 libXrender                     x86_64   0.9.10-7.el8                                         rhel-8-for-x86_64-appstream-rpms    33 k
 libappstream-glib              x86_64   0.7.14-3.el8                                         rhel-8-for-x86_64-baseos-rpms      338 k
 libmodman                      x86_64   2.0.1-17.el8                                         rhel-8-for-x86_64-baseos-rpms       36 k
 libnet                         x86_64   1.1.6-15.el8                                         rhel-8-for-x86_64-appstream-rpms    67 k
 libproxy                       x86_64   0.4.15-5.2.el8                                       rhel-8-for-x86_64-baseos-rpms       74 k
 libsoup                        x86_64   2.62.3-1.el8                                         rhel-8-for-x86_64-baseos-rpms      424 k
 libstemmer                     x86_64   0-10.585svn.el8                                      rhel-8-for-x86_64-baseos-rpms       73 k
 libvarlink                     x86_64   18-3.el8                                             rhel-8-for-x86_64-baseos-rpms       44 k
 libxcb                         x86_64   1.13.1-1.el8                                         rhel-8-for-x86_64-appstream-rpms   229 k
 pixman                         x86_64   0.38.4-1.el8                                         rhel-8-for-x86_64-appstream-rpms   257 k
 policycoreutils-python-utils   noarch   2.9-9.el8                                            rhel-8-for-x86_64-baseos-rpms      251 k
 protobuf-c                     x86_64   1.3.0-4.el8                                          rhel-8-for-x86_64-appstream-rpms    37 k
 python3-cairo                  x86_64   1.16.3-6.el8                                         rhel-8-for-x86_64-appstream-rpms    90 k
 python3-gobject                x86_64   3.28.3-1.el8                                         rhel-8-for-x86_64-appstream-rpms    25 k
 python3-psutil                 x86_64   5.4.3-10.el8                                         rhel-8-for-x86_64-appstream-rpms   373 k
 python3-systemd                x86_64   234-8.el8                                            rhel-8-for-x86_64-appstream-rpms    81 k
 setroubleshoot-plugins         noarch   3.3.11-2.el8                                         rhel-8-for-x86_64-appstream-rpms   360 k
Installing weak dependencies:
 PackageKit                     x86_64   1.1.12-4.el8                                         rhel-8-for-x86_64-appstream-rpms   599 k
 abattis-cantarell-fonts        noarch   0.0.25-4.el8                                         rhel-8-for-x86_64-appstream-rpms   155 k
 setroubleshoot-server          x86_64   3.3.22-2.el8                                         rhel-8-for-x86_64-appstream-rpms   398 k
Installing module profiles:
 container-tools/common                                                                                                               
Enabling module streams:
 container-tools                         rhel8                                                                                        

Transaction Summary
=======================================================================================================================================
Install  51 Packages

Total download size: 64 M
Installed size: 240 M
Is this ok [y/N]:


Isn't it possible you have something wrong with your repositories configuration? AppStream repo should be automatically configured by subscription manager in /etc/yum.repos.d/redhat.repo file.

Comment 3 Marek Blaha 2020-10-26 12:57:44 UTC
Oh, according to the bug title you want to install stream 1.0 of the module. Then the command should be:

# dnf module install container-tools:1.0
Updating Subscription Management repositories.
Last metadata expiration check: 0:23:37 ago on Mon Oct 26 08:31:57 2020.
Dependencies resolved.
=======================================================================================================================================
 Package                      Arch   Version                                                    Repository                        Size
=======================================================================================================================================
Installing group/module packages:
 buildah                      x86_64 1.5-6.gite94b4f9.module+el8.1.0+4908+72a45cef              rhel-8-for-x86_64-appstream-rpms 5.7 M
 container-selinux            noarch 2:2.124.0-1.gitf958d0c.module+el8.2.0+6370+6fb6c8ca        rhel-8-for-x86_64-appstream-rpms  45 k
 containernetworking-plugins  x86_64 0.7.4-4.git9ebe139.module+el8.1.0+4908+72a45cef            rhel-8-for-x86_64-appstream-rpms  15 M
 criu                         x86_64 3.12-9.module+el8.2.0+6370+6fb6c8ca                        rhel-8-for-x86_64-appstream-rpms 482 k
 fuse-overlayfs               x86_64 0.3-5.module+el8.2.0+6370+6fb6c8ca                         rhel-8-for-x86_64-appstream-rpms  48 k
 oci-systemd-hook             x86_64 1:0.1.15-2.git2d0b8a3.module+el8+2650+e6b3d617             rhel-8-for-x86_64-appstream-rpms  39 k
 oci-umount                   x86_64 2:2.3.4-2.git87f9237.module+el8+2650+e6b3d617              rhel-8-for-x86_64-appstream-rpms  38 k
 podman                       x86_64 1.0.0-4.git921f98f.module+el8.2.0+6370+6fb6c8ca            rhel-8-for-x86_64-appstream-rpms 9.5 M
 runc                         x86_64 1.0.0-56.rc5.dev.git2abd837.module+el8.2.0+6370+6fb6c8ca   rhel-8-for-x86_64-appstream-rpms 2.5 M
 skopeo                       x86_64 1:0.1.32-6.git1715c90.module+el8.1.0+4903+9bde5d6c         rhel-8-for-x86_64-appstream-rpms 5.2 M
 slirp4netns                  x86_64 0.1-5.dev.gitc4e1bc5.module+el8.2.0+6370+6fb6c8ca          rhel-8-for-x86_64-appstream-rpms  55 k
Installing dependencies:
 containers-common            x86_64 1:0.1.32-6.git1715c90.module+el8.1.0+4903+9bde5d6c         rhel-8-for-x86_64-appstream-rpms  32 k
 fuse3-libs                   x86_64 3.2.1-12.el8                                               rhel-8-for-x86_64-baseos-rpms     94 k
 libnet                       x86_64 1.1.6-15.el8                                               rhel-8-for-x86_64-appstream-rpms  67 k
 ostree-libs                  x86_64 2019.6-2.el8                                               rhel-8-for-x86_64-appstream-rpms 395 k
 policycoreutils-python-utils noarch 2.9-9.el8                                                  rhel-8-for-x86_64-baseos-rpms    251 k
 protobuf-c                   x86_64 1.3.0-4.el8                                                rhel-8-for-x86_64-appstream-rpms  37 k
 yajl                         x86_64 2.1.0-10.el8                                               rhel-8-for-x86_64-appstream-rpms  41 k
Installing module profiles:
 container-tools/common                                                                                                               
Enabling module streams:
 container-tools                     1.0                                                                                              

Transaction Summary
=======================================================================================================================================
Install  18 Packages

Total download size: 39 M
Installed size: 144 M
Is this ok [y/N]:

Comment 4 pbajjuri 2020-10-26 14:47:28 UTC
This issue fixed, you can close the ticket!

Comment 5 Marek Blaha 2020-10-26 15:00:21 UTC
OK, thanks.


Note You need to log in before you can comment on or make changes to this bug.