Bug 1889491 - filters being removed after sort by display_name
Summary: filters being removed after sort by display_name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Cloud Software Services (cloud.redhat.com)
Classification: Red Hat
Component: Inventory
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Shaun Dunning
QA Contact: Rodrigo Antunes
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-19 18:50 UTC by Shaun Dunning
Modified: 2020-10-23 16:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-23 16:33:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shaun Dunning 2020-10-19 18:50:44 UTC
Description of problem:

When sorting by the cols in the inventory, the insights-client filter is removed / not present in the url (but the chip is still present on the UI).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. go to /inventory
2. notice the number of systems on load
3. sort by any col
4. notice that the number of systems change


Expected results:
Number of systems do not change when sorting by columns.

Additional info:

Issue appears to be with the source filter is not present in the url on initial load. If you clear the filters and reapply the filters notice that the source filter gets appended to the url and the sorting behavior works as expected.


Note You need to log in before you can comment on or make changes to this bug.