Bug 188972 - GNOME Power Manager won't start
GNOME Power Manager won't start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-13 21:44 EDT by Andrig Miller
Modified: 2013-03-13 00:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 13:56:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot that shows the error dialog, and the contents of the GNOME session side-by-side. (266.49 KB, image/png)
2006-04-13 21:44 EDT, Andrig Miller
no flags Details
ps aux | grep dbus output (1.97 KB, text/plain)
2006-04-18 10:51 EDT, Andrig Miller
no flags Details

  None (edit)
Description Andrig Miller 2006-04-13 21:44:29 EDT
Description of problem:  The GNOME power manager complains that it cannot start
until the dbus session service is started, but I have it started and listed in
the GNOME session.


Version-Release number of selected component (if applicable): 2.14.1-1


How reproducible:  Everytime I log in.


Steps to Reproduce:
1.Turn on power manager.
2.Logoff
3.Login
  
Actual results: Power manager error dialog pops up with the message that states
that the power manager cannot start until the dbus session service is started. 
It goes on to say that you can start the dbus session service manually with the
following command:

eval 'dbus-launch --auto-syntax'



Expected results: Power manager should start, because the dbus session service
is started, and is listed in the GNOME session.


Additional info:
Comment 1 Andrig Miller 2006-04-13 21:44:29 EDT
Created attachment 127736 [details]
Screen shot that shows the error dialog, and the contents of the GNOME session side-by-side.
Comment 2 Richard Hughes 2006-04-14 04:26:09 EDT
I'm lost to why whis would happen. J5, got any ideas?
Comment 3 John (J5) Palmieri 2006-04-17 17:48:33 EDT
Just got back from vacation.  Is dbus running?
Comment 4 Andrig Miller 2006-04-17 22:17:09 EDT
The attached screen shot says it all!  DBUS is running.
Comment 5 John (J5) Palmieri 2006-04-18 09:25:41 EDT
Arggg, error message is wrong - Richard take that out.  You can't just start a
session bus and expect it to work.  Plus dbus-launch is not the same as dbus. 
dbus-launch just launches dbus and manages its lifecycle.  The dbus session
should be started by your xsession.  Please reboot, login fresh and attach the
output of ps -aux | grep dbus to this bug.  Thanks.

Error messages should never give instructions, just diagnostics because they
always end up confusing the user.
Comment 6 Andrig Miller 2006-04-18 10:51:25 EDT
Created attachment 127921 [details]
ps aux | grep dbus output

Here is the ps output
Comment 7 Richard Hughes 2006-04-18 12:48:02 EDT
(In reply to comment #5)
> Error messages should never give instructions, just diagnostics because they
> always end up confusing the user.

Understood:

2006-04-18  Richard Hughes  <richard@hughsie.com>
 * src/gpm-main.c (main): Don't tell the user to use dbus-launch as it's the
wrong way to do this. rh:188972

I'll commit this to 2-14 and 2-15 now.
Comment 8 John (J5) Palmieri 2006-04-19 10:56:44 EDT
 Andrig, did you reboot?  You have 13 dbus instances running.  Another thing to
do is check to see if /usr/bin/dbus-daemon exists.  It shouldn't and if it is
still there then you had an upgrade error and I would bet rpm -q dbus would show
more than one version installed. 
Comment 9 Andrig Miller 2006-04-19 13:39:38 EDT
I hadn't rebooted at that time, but I had switched runlevels a number of times.
 I do have the /usr/bin/dbus-daemon, and rpm -q shows two dbus, but I believe
they are the 32-bit version and the 64-bit version, not two different ones. 
Here is what it looks like:

cd /usr/bin
[root@localhost bin]# ls -laF dbus-daemon
-rwxr-xr-x 1 root root 596744 Aug 29  2005 dbus-daemon*
[root@localhost bin]# rpm -q dbus
dbus-0.61-3
dbus-0.61-3

I have a lot of 32-bit and 64-bit applications mixed on my machine, and that is
probably why I have two.  Can I just remove the dbus-daemon from /usr/bin?
Comment 10 John (J5) Palmieri 2006-04-19 13:56:30 EDT
Have you ever installed dbus from source?  Do a rpm -qf /usr/bin/dbus-daemon and
post the results.  Thanks.
Comment 11 Andrig Miller 2006-04-19 14:39:13 EDT
Interestingly, that file is not owned by any package, as you can see here:

[root@localhost ~]# rpm -qf /usr/bin/dbus-daemon
file /usr/bin/dbus-daemon is not owned by any package

But, I have never installed dbus from source before.
Comment 12 John (J5) Palmieri 2006-04-19 14:52:51 EDT
For some reason it never got removed on upgrade.  Remove it and reboot to see if
that fixes things.
Comment 13 Andrig Miller 2006-04-19 23:01:48 EDT
I removed it and rebooted, and now everything is working.  Thanks for the help.
 I really appreciate it.

Note You need to log in before you can comment on or make changes to this bug.