Bug 188978 - Pirut doen't know what is or isn't installed any more
Pirut doen't know what is or isn't installed any more
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 02:07 EDT by Ian Laurie
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 20:44:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2006-04-14 02:07:26 EDT
Description of problem:
pirut has lost the plot and is confused as to what is and isn't installed.
For example, according to pirut browse mode, neither KDE or GNOME is installed,
whereas both in fact are.

Version-Release number of selected component (if applicable):
pirut-1.0.1-1

How reproducible:
Always.

Steps to Reproduce:
1. Launch "Add/Remove Software"
2.
3.
  
Actual results:
In Browse mode, almost no checkboxes are checked in any group, even though
virtually everything has been installed.

Expected results:
Should show what is installed like it used to do.

Additional info:
If I launch pirut from a command line this is what I get:

rpmdb: read: 0xb5b8672c, 4096: Input/output error
error: db4 error(5) from dbcursor->c_get: Input/output error

Is there any way to get pirut to re-learn what is on the system?
Comment 1 Paul Nasrat 2006-04-14 10:25:50 EDT
can you rm -f /var/lib/rpm/__db* and retry.  If it still fails, please tar up
/var/lib/rpm and put on a website so I can look at.  Can you also check dmesg
for disk failure messages EIO can indicate h/w failure.
Comment 2 Ian Laurie 2006-04-14 20:44:54 EDT
1. rm -f /var/lib/rpm/__db* makes no difference.
2. No problems in dmesg..... BUT....... I get errors taring the directory, and
also when trying to copy the directory.

in /var/log/messages:

Apr 15 10:33:03 zaurak kernel: hda: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Apr 15 10:33:03 zaurak kernel: hda: dma_intr: error=0x40 { UncorrectableError },
LBAsect=37714724, sector=37714722
Apr 15 10:33:03 zaurak kernel: ide: failed opcode was: unknown
Apr 15 10:33:03 zaurak kernel: end_request: I/O error, dev hda, sector 37714722
Apr 15 10:33:08 zaurak kernel: hda: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Apr 15 10:33:08 zaurak kernel: hda: dma_intr: error=0x40 { UncorrectableError },
LBAsect=37714724, sector=37714722
Apr 15 10:33:08 zaurak kernel: ide: failed opcode was: unknown
Apr 15 10:33:08 zaurak kernel: end_request: I/O error, dev hda, sector 37714722
Apr 15 10:44:02 zaurak kernel: hda: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Apr 15 10:44:02 zaurak kernel: hda: dma_intr: error=0x40 { UncorrectableError },
LBAsect=37714724, sector=37714722
Apr 15 10:44:02 zaurak kernel: ide: failed opcode was: unknown
Apr 15 10:44:02 zaurak kernel: end_request: I/O error, dev hda, sector 37714722
Apr 15 10:47:10 zaurak kernel: hda: dma_intr: status=0x51 { DriveReady
SeekComplete Error }
Apr 15 10:47:10 zaurak kernel: hda: dma_intr: error=0x40 { UncorrectableError },
LBAsect=37714724, sector=37714722
Apr 15 10:47:10 zaurak kernel: ide: failed opcode was: unknown
Apr 15 10:47:10 zaurak kernel: end_request: I/O error, dev hda, sector 37714722

Looks like I have to replace the H/D and reinstall everything :(

Sorry for the bogus bug report.

Note You need to log in before you can comment on or make changes to this bug.