Bug 188981 - RHEL4: "sfdisk -l" tries to open partitions
RHEL4: "sfdisk -l" tries to open partitions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
: 193653 194493 (view as bug list)
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-04-14 03:16 EDT by Karel Zak
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0406
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:43:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2006-04-14 03:16:21 EDT
+++ This bug was initially created as a clone of Bug #188488 +++

Doing an "sfdisk -l" will try to open partitions as if they were disks, and fail
to read the partition table.

Patch attached. It makes use of the same is_probably_full_disk() as fdisk.

-- Additional comment from bnocera@redhat.com on 2006-04-10 11:54 EST --
Created an attachment (id=127554)
util-linux-sfdisk-dont-open-partitions.patch
Comment 4 Karel Zak 2006-05-31 11:30:05 EDT
*** Bug 193653 has been marked as a duplicate of this bug. ***
Comment 5 Karel Zak 2006-06-08 15:30:22 EDT
*** Bug 194493 has been marked as a duplicate of this bug. ***
Comment 11 Red Hat Bugzilla 2006-08-10 17:43:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0406.html

Note You need to log in before you can comment on or make changes to this bug.