Bug 188983 - Annoying pseudoterminal allocation message
Annoying pseudoterminal allocation message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 03:29 EDT by David Nečas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: openssh-4.3p2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-14 04:33:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nečas 2006-04-14 03:29:58 EDT
Description of problem:
When scp is invoked noninteractively (from cron, at, etc.) to copy between two
different machines, it prints an annoying and useless message:

Pseudo-terminal will not be allocated because stdin is not a terminal.

Options -qB that clearly indicate the intent of quiet batch processing do not help.


Version-Release number of selected component (if applicable):
openssh-clients-4.3p2-4


How reproducible:
Always


Steps to Reproduce:
1. touch test
2. scp -qB localhost:test localhost: </dev/null

  
Actual results:
Pseudo-terminal will not be allocated because stdin is not a terminal.
Permission denied (publickey,keyboard-interactive).


Expected results:
Permission denied (publickey,keyboard-interactive).


Additional info:
The purpose of </dev/null in the test case is to simulate non-tty stdin, as the
real-world noninteractive use cases would involve more complex setup.
Comment 1 Tomas Mraz 2006-04-14 04:33:05 EDT
Fixed version will appear in FC-devel.

Note You need to log in before you can comment on or make changes to this bug.