Bug 188989 - xorg crashes on trident cyberblade at 1024x768
xorg crashes on trident cyberblade at 1024x768
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-trident (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 05:57 EDT by Chris Edsall
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 15:45:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log featuring a backtrace (41.67 KB, text/plain)
2006-04-15 05:37 EDT, Chris Edsall
no flags Details
kernel log messages generated when X crashed (3.10 KB, text/plain)
2006-04-15 05:39 EDT, Chris Edsall
no flags Details

  None (edit)
Description Chris Edsall 2006-04-14 05:57:45 EDT
Description of problem:

Reinstalling on a box that previously ran FC2 without incident, X now crasshes a
random short ammount of time after startup. The hardware is a Trident
CyberBlade/i1 (rev 6a) built into the motherboard of a VIA system. Most times
the system just hangs but on one occasion there was screen corruption - vertical
stipes in the centre third of the screen that increased in number every few seconds.

Bizzarely this only happens at a resolutuon of 1024x768 (both 70Hz both 60Hz
refresh). Running at 800x600 the system is rock solid.

Version-Release number of selected component (if applicable):

[root@localhost ~]# cat /etc/issue
Fedora Core release 5 (Bordeaux)

[root@localhost ~]# rpm -q xorg-x11-server-Xorg xorg-x11-drv-trident
xorg-x11-server-Xorg-1.0.1-9
xorg-x11-drv-trident-1.0.1.2-1.2

The FC5 release had the problem, updated via yum update and the problem remains.

How reproducible:

Every time booting in to X with resolution at 1024x768 - within 10 mins or so
the system will lock up. Still stable after hours at 800x600

Steps to Reproduce:
1. Boot to runlevel 5
2. wait for crash
3. profit!
  
Actual results:
X hangs, keayboard and mouse non functional => hit the big red button. One time
there was screen corruption

Expected results:

Stability at higher resolutions


Additional info:

[root@localhost ~]# lspci -v
 ...
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 6a)
(prog-if 00 [VGA])
        Subsystem: ASUSTeK Computer Inc. Unknown device 806f
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
        Memory at f7000000 (32-bit, non-prefetchable) [size=8M]
        Memory at f6800000 (32-bit, non-prefetchable) [size=128K]
        Memory at f6000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at f7ff0000 [disabled] [size=64K]
        Capabilities: [80] AGP version 1.0
        Capabilities: [90] Power Management version 1
Comment 1 Chris Edsall 2006-04-15 05:37:47 EDT
Created attachment 127776 [details]
Xorg.0.log featuring a backtrace

This was generated by switching back to the first virtaul console while startx
was starting various gnome things
Comment 2 Chris Edsall 2006-04-15 05:39:42 EDT
Created attachment 127777 [details]
kernel log messages generated when X crashed
Comment 3 Mike A. Harris 2006-05-23 09:00:22 EDT
If this issue turns out to still be reproduceable in the latest
updates for this Fedora Core release, please file a bug report
in the X.Org bugzilla located at http://bugs.freedesktop.org in
the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug report URL for tracking.

Thanks in advance.
Comment 4 Mike A. Harris 2006-07-27 15:45:15 EDT
Assuming issue is no longer present in rawhide as there have been no updates
to this report since the last comment.  If the problem is still reproduceable
in rawhide, please report the issue upstream as indicated above, and we will
track it there, and update the driver when a fix is available.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.