Bug 188992 - EMU10K1 Default PCM Device is missing...
EMU10K1 Default PCM Device is missing...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 07:17 EDT by Phil
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-30 11:12:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the audio devices window (28.70 KB, image/png)
2006-04-14 07:17 EDT, Phil
no flags Details
scsound.log - as per request (7.47 KB, application/octet-stream)
2006-04-19 00:35 EDT, Phil
no flags Details

  None (edit)
Description Phil 2006-04-14 07:17:41 EDT
Description of problem:
When starting system-config-soundcard, from shell produces the error "amixer:
Mixer attach default error: No such file or directory" before loading.  once
loaded i can select a "Default PCM device" for my on board VIA audio card but
when i select my soundblaster emu10k1 there is no option in that field and
programs such as xine and others have no sound system - unless manually
configured.  i can get xmms to work after manually selecting a device in its
config.  from past experience knew that running most gui apps from the cmd line
gave verbose output which is where i found the first error.

the sound test works fine.


Version-Release number of selected component (if applicable):
system-config-soundcard 1.2.16-2


How reproducible:
very, all i have to do is load it...
  

Additional info:
i have tried disabling my onboard audio to no effect.
Comment 1 Phil 2006-04-14 07:17:41 EDT
Created attachment 127743 [details]
screenshot of the audio devices window
Comment 2 Martin Stransky 2006-04-18 16:21:24 EDT
Could you please attach /root/scsound.log?
Comment 3 Phil 2006-04-19 00:35:14 EDT
Created attachment 127971 [details]
scsound.log - as per request
Comment 4 Phil 2006-04-23 02:44:35 EDT
mplayer has never been able to play any sound - video works fine - every time i
start a video it gives me an error message (see below). the default selectable
audio devices are hw=0,0, 0,1 or 0,2. The way that i was able to get xmms to
work was to manually select hw=1,0.  i manually entered hw1,0 as the device and
i was able to get sound, all be it with 5 billion error messages flashing up on
my screen.  the error was this:

alsa-control: mixer attach default error: No such device

which is the same error as the first time except this time it's flashing up 5
billion times - i can stop the video at any time, it doesn't lock up - but now
i'm getting sound.

i'm thinking that since alsa is defaulting to trying to look for device 0 only,
this may be the problem that's preventing system-config-sound from seeing my card.

When i run aplay from the cmd prompt i get this error message:

[root@harlequin dev]# aplay
ALSA lib confmisc.c:672:(snd_func_card_driver) cannot find card '0'
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_card_driver
returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_concat returned
error: No such device
ALSA lib confmisc.c:1072:(snd_func_refer) error evaluating name
ALSA lib conf.c:3492:(_snd_config_evaluate) function snd_func_refer returned
error: No such device
ALSA lib conf.c:3961:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2099:(snd_pcm_open_noupdate) Unknown PCM default
aplay: main:547: audio open error: No such device


can this bug be transfered to being a bug in alsa or do i have to make a
seperate bug report??

regards,
phil
Comment 5 Phil 2006-04-23 03:31:01 EDT
cool, i've had some more success.  i'm not going to go in to how i got on to
asound.conf but manually editting that file was the key to success.

Original:
#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

i changed both card entries to 1 , the device should stay 0 as per the output of
"aplay -l"

[root@harlequin ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Live [SB Live 5.1], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 28/32
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
  Subdevice #8: subdevice #8
  Subdevice #9: subdevice #9
  Subdevice #10: subdevice #10
  Subdevice #11: subdevice #11
  Subdevice #12: subdevice #12
  Subdevice #13: subdevice #13
  Subdevice #14: subdevice #14
  Subdevice #15: subdevice #15
  Subdevice #16: subdevice #16
  Subdevice #17: subdevice #17
  Subdevice #18: subdevice #18
  Subdevice #19: subdevice #19
  Subdevice #20: subdevice #20
  Subdevice #21: subdevice #21
  Subdevice #22: subdevice #22
  Subdevice #23: subdevice #23
  Subdevice #24: subdevice #24
  Subdevice #25: subdevice #25
  Subdevice #26: subdevice #26
  Subdevice #27: subdevice #27
  Subdevice #28: subdevice #28
  Subdevice #29: subdevice #29
  Subdevice #30: subdevice #30
  Subdevice #31: subdevice #31
card 1: Live [SB Live 5.1], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: Live [SB Live 5.1], device 3: emu10k1 [Multichannel Playback]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

so the prob apears to be with system-config-sound after all.  this is the part
that's beyond me :) hope i've given you guys enough info fix this lil bug.

regards,

phil
Comment 6 Martin Stransky 2006-04-28 02:15:03 EDT
Thanks for your report, it's bug in system-config-soundcard.
Comment 7 Martin Stransky 2006-06-30 11:12:54 EDT
Should be fixed in s-c-s now.

Note You need to log in before you can comment on or make changes to this bug.