Bug 1889975 - loadable library and perl binaries are mismatched
Summary: loadable library and perl binaries are mismatched
Keywords:
Status: CLOSED DUPLICATE of bug 1891366
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 32
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-10-21 06:51 UTC by FlyDove
Modified: 2020-10-26 10:13 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-26 10:13:45 UTC
Type: Bug


Attachments (Terms of Use)

Description FlyDove 2020-10-21 06:51:39 UTC
loadable library and perl binaries are mismatched (got handshake key 0xce00080, needed 0xcd00080)

Comment 1 Petr Pisar 2020-10-21 07:53:06 UTC
This happens after upgrading perl interpreter to a new major version (e.g. from 5.28 to 5.30) if you have installed a locally built Perl modules from CPAN. Is that your case? What module file do you attempt to load when you get the error? If it so, you need to rebuild (or remove) the locally built modules after the upgrade.

Comment 2 FlyDove 2020-10-26 03:02:29 UTC
$ sudo systemctl restart webmin
Job for webmin.service failed because the control process exited with error code.
See "systemctl status webmin.service" and "journalctl -xe" for details.
[Fedora@MiWiFi-R4-srv packages]$ sudo systemctl status webmin
● webmin.service - LSB: web-based administration interface for Unix systems
     Loaded: loaded (/etc/rc.d/init.d/webmin; generated)
     Active: failed (Result: exit-code) since Mon 2020-10-26 09:56:00 CST; 4s ago
       Docs: man:systemd-sysv-generator(8)
    Process: 33825 ExecStart=/etc/rc.d/init.d/webmin start (code=exited, status=1/FAILURE)
        CPU: 86ms

10月 26 09:56:00 MiWiFi-R4-srv systemd[1]: Starting LSB: web-based administration interface for Unix systems...
10月 26 09:56:00 MiWiFi-R4-srv systemd[1]: webmin.service: Control process exited, code=exited, status=1/FAILURE
10月 26 09:56:00 MiWiFi-R4-srv systemd[1]: webmin.service: Failed with result 'exit-code'.
10月 26 09:56:00 MiWiFi-R4-srv systemd[1]: Failed to start LSB: web-based administration interface for Unix systems.



$ sudo  /etc/rc.d/init.d/webmin restart
Stopping Webmin server in /usr/libexec/webmin
Starting Webmin server in /usr/libexec/webmin
Socket6.c: loadable library and perl binaries are mismatched (got handshake key 0xce00080, needed 0xcd00080)

Comment 3 Petr Pisar 2020-10-26 10:13:45 UTC

*** This bug has been marked as a duplicate of bug 1891366 ***


Note You need to log in before you can comment on or make changes to this bug.