Bug 188998 - qtparted resize reports failed; linux/macos see different partion maps
qtparted resize reports failed; linux/macos see different partion maps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
5
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
: 189000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-14 11:12 EDT by Robert Story
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-21 10:55:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Story 2006-04-14 11:12:00 EDT
Description of problem:
I used qtparted to try and shrink a hfs+ partition. it reported that the action
failed due to partions being mounted (I don't even know how to mount hfs+!), and
parted/pdisk show the original partition map. upon rebooting into macsox, macosx
and it's pdisk report the shrinked size.

Version-Release number of selected component (if applicable):
parted-1.6.25-8
0.4.5-4.fc5

How reproducible:
always

Steps to Reproduce:
1. shrink hfs+ partition using parted
2.
3.
  
Actual results:
parted returns error

Expected results:
parted returns success

Additional info:
Comment 1 David Cantrell 2006-04-25 11:11:48 EDT
Can you try performing this operation with just the parted command and not the
qtparted frontend?  Attach any core files or error messages that you see.
Comment 2 David Cantrell 2006-04-25 11:27:36 EDT
*** Bug 189000 has been marked as a duplicate of this bug. ***
Comment 4 David Cantrell 2007-03-21 10:55:48 EDT
HFS+ resize support is present in parted-1.8.6 in rawhide.  Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.