Bug 18900 - upgrade fails on RAID entry in fstab (dump attached)
Summary: upgrade fails on RAID entry in fstab (dump attached)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 19239 19298 33594 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-11 15:55 UTC by heckmann
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 19:57:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file (2.61 KB, text/plain)
2000-10-11 15:55 UTC, heckmann
no flags Details
My fstab (976 bytes, text/plain)
2000-10-29 00:15 UTC, heckmann
no flags Details

Description heckmann 2000-10-11 15:55:02 UTC
I tried the anaconda update disk that came out on 2000-10-10, during an
upgrade install, when it gets to examining system, it fails on my raid
entry in /etc/fstab. The failure happens on raidByDev in fstab.py. This
could be a duplicate of the bug with the mixed SCSI + IDE raid1 device
since this is what I have as well. Traceback + dump attached.

Comment 1 heckmann 2000-10-11 15:55:59 UTC
Created attachment 4065 [details]
anaconda dump file

Comment 2 Michael Fulbright 2000-10-19 21:35:26 UTC
*** Bug 19239 has been marked as a duplicate of this bug. ***

Comment 3 Michael Fulbright 2000-10-19 21:44:17 UTC
*** Bug 19298 has been marked as a duplicate of this bug. ***

Comment 4 Michael Fulbright 2000-10-27 19:59:14 UTC
Could you attach your fstab file as well?

Comment 5 heckmann 2000-10-27 20:09:29 UTC
Ok, I'll do it when I get home tonight.

Comment 6 heckmann 2000-10-29 00:15:16 UTC
Created attachment 4733 [details]
My fstab

Comment 7 Manfred Spraul 2000-12-02 19:03:02 UTC
Could you add the partition table?
I assume your partition is of type 0x82 (ext2) instead of 0xfd raid.
See bug 18508. IMHO the current code is a bug

------- Additional comments from msf@redhat.com 2000-10-06 02:07 -------
All RAID devices are assumed to be type 0xfd.

You can probably complete your upgrade by just commenting out the line in
/etc/fstab containing the RAID device, unless it contains files the upgrade will
touch. Then uncomment it after you reboot after the upgrade.


Comment 8 Michael Fulbright 2001-01-19 21:25:29 UTC
Have you had any luck getting around this issue?

Comment 9 Manfred Spraul 2001-01-28 22:39:37 UTC
>
> Have you had any luck getting around this issue?
>
I'm not who you means with 'you', but I got around the bug by changing the
partition type to 0xfd.



Comment 10 Michael Fulbright 2001-02-01 19:57:03 UTC
Thank you for the feedback.

We require RAID partitions to be type 0xfd.

Comment 11 Manfred Spraul 2001-02-02 17:17:13 UTC
It's your installer, but IMHO this is a bug:

I agree that the partition type should be 0xfd, but anaconda must not crash -
especially since a wrong partition type usually doesn't matter.

Can't you add bounds checks and a nice message box?



Comment 12 Brent Fox 2001-03-30 21:32:14 UTC
*** Bug 33594 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.