Bug 189024 - hp-setup erroneously picks up fax ppd for printer ppd
hp-setup erroneously picks up fax ppd for printer ppd
Status: CLOSED DUPLICATE of bug 186213
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2006-04-14 17:43 EDT by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-17 12:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2006-04-14 17:43:48 EDT
Description of problem:
When hp-setup is run the fax ppd is picked up for the printer ppd.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. hp-setup <ip.addr>
Actual results:
[root@localhost /]# hp-setup

HP Linux Imaging and Printing System (ver. 0.9.10)
Printer/Fax Setup Utility ver. 2.0

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Setting up device: hp:/net/HP_Color_LaserJet_2840?ip=

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept
the default.)


Please enter a name for this print queue (m=use model
name:'HP_Color_LaserJet_2840'*, q=quit) ?
Using queue name: HP_Color_LaserJet_2840

Found a possible PPD file: /usr/share/ppd/HP/fax/HP-Fax-hplip.ppd.gz
Note: The model number may vary slightly from the actual model number on the device.

Does this PPD file appear to be the correct one (y=yes*, n=no, q=quit) ?n
 [ERROR]: Unable to find an appropriate PPD file.

Would you like to specify the path to the correct PPD file to use (y=yes, n=no*,
q=quit) ?y

Description for the file: HP Color LaserJet 2800 Series Postscript (recommended)
Use this file (y=yes*, n=no, q=quit) ?y
Enter a location description for this printer (q=quit) ?MyNetwork
Enter additonal information or notes for this printer (q=quit) ?

Adding print queue to CUPS:
Device URI: hp:/net/HP_Color_LaserJet_2840?ip=
Queue name: HP_Color_LaserJet_2840
PPD file:
Location: MyNetwork

Expected results:
Find the right file for the printer.

Additional info:
Comment 1 Bernard Johnson 2006-04-17 12:41:01 EDT
Although the behavior is different, this bug is caused by the same source as 

*** This bug has been marked as a duplicate of 186213 ***

Note You need to log in before you can comment on or make changes to this bug.