Bug 18905 - MySQL output not the same as the tutorial
MySQL output not the same as the tutorial
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
: 20391 (view as bug list)
Depends On: 19604
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-11 12:58 EDT by Lee Howard
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-25 14:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Howard 2000-10-11 12:58:35 EDT
I'm using RedHat 7.0 with:

mysql-3.23.24-1
mysql-devel-3.23.24-1
mysql-server-3.23.24-1

I'm following the MySQL manual Chapter 9: Tutorial, and I'm not getting the
same responses as the manual shows.  I don't understand the problem.  This 
doesn't happen with RedHat 6.1 with RPMs from mysql.com:

MySQL-client-3.22.32-1
MySQL-shared-3.22.32-1
MySQL-3.22.32-1

This is the output on Guinness:

mysql> SELECT VERSION();
+------------------+
| VERSION()        |
+------------------+
| 3.23.24-beta-log |
+------------------+
1 row in set (0.00 sec)

mysql> SELECT * FROM shop;
+---------+--------+-------+
| article | dealer | price |
+---------+--------+-------+
|    0001 | A      |  3.45 |
|    0001 | B      |  3.99 |
|    0002 | A      | 10.99 |
|    0003 | B      |  1.45 |
|    0003 | C      |  1.69 |
|    0003 | D      |  1.25 |
|    0004 | D      | 19.95 |
+---------+--------+-------+
7 rows in set (0.00 sec)

mysql> SELECT article, MAX(price) AS price
    -> FROM shop
    -> GROUP BY article;
+---------+-------+
| article | price |
+---------+-------+
|    0001 |  0.00 |
|    0002 |  8.27 |
|    0003 |  0.00 |
|    0004 |  8.27 |
+---------+-------+
4 rows in set (0.00 sec)

Compare that bottom output with the one above it.  That's totally 
different from what it should be.  Something is really wrong here.  Is it 
me?  Any ideas?

Thanks.

Lee Howard
Comment 1 Trond Eivind Glomsrxd 2000-10-17 10:07:25 EDT
Verified... seems to be compiler related (does not happen on 6.2, happens on 6.2
with nw compiler). Jakub?
Comment 2 Trond Eivind Glomsrxd 2000-10-18 16:59:33 EDT
Fixed in 3.23.26-1, which I plan on releasing as a bugfix update. Thanks for the
report, it was very helpful.
Comment 3 Trond Eivind Glomsrxd 2000-10-23 10:43:09 EDT
Sorry, not fixed in -1. Workaround is to compile with -01.
Comment 4 Trond Eivind Glomsrxd 2000-10-25 15:03:04 EDT
Fixed in 3.23.26-1.2, which includes the patch mentioned in bug #19604. It has
been upstreamed, and I expect to release an errata later.
Comment 5 Jakub Jelinek 2000-11-05 15:22:04 EST
*** Bug 20391 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.