Bug 189069 - old and new versions of web pages exist and aren't interlinked
old and new versions of web pages exist and aren't interlinked
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Websites Team
Karsten Wade
:
: 175166 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-15 07:54 EDT by Michael De La Rue
Modified: 2009-08-05 14:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-14 09:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes redirections (152.57 KB, patch)
2006-10-12 20:45 EDT, Dimitris Glezos
no flags Details | Diff
Patch 2 that makes 2 links of previous one better (1.25 KB, text/x-patch)
2006-10-13 17:18 EDT, Dimitris Glezos
no flags Details

  None (edit)
Description Michael De La Rue 2006-04-15 07:54:07 EDT
The default page for "fedora download" on google
(http://www.google.com/search?ie=UTF8&q=fedora+download) is 

http://fedora.redhat.com/download/

which is the FC4 version.  Probably that should be replaced with a redirect to 

http://fedora.redhat.com/Download/

If not, at least there should be a link forward to the new version.  Maybe the
new page should also maybe have a link to old versions??  

At the same time the Xen documentation has similar problems.  The old page

http://fedora.redhat.com/projects/virtualization/
and google
http://www.google.com/search?ie=UTF8&q=xen+fedora+core

link to the fedora core 4 quick start page.  

http://www.fedoraproject.org/wiki/FedoraXenQuickstart

whilst there is a new one 

http://www.fedoraproject.org/wiki/FedoraXenQuickstartFC5

probably there should be links to both from each place.
Comment 1 Thorsten Leemhuis 2006-07-16 12:21:57 EDT
Some more "old" websites that need redirects:

http://fedora.redhat.com/about/
http://fedora.redhat.com/projects/
http://fedora.redhat.com/participate/
http://fedora.redhat.com/participate/communicate/

the new ones are

http://fedora.redhat.com/About/
http://fedora.redhat.com/Contribute/

There are probably more -- someomne should run find and grep on the server to
look out for other old stuff taht's still around
Comment 2 Patrick Barnes 2006-10-01 01:04:44 EDT
Okay, web-members, I know that many of you have been looking for ways to 
contribute.  This is your chance.

Each of the old pages needs a redirect similar to:

http://fedora.redhat.com/download/

This follows a basic PHP template.  We do not have the option of using 
automatic redirects, so this is our best option.

Following the Websites CVS instructions:

http://fedoraproject.org/wiki/Websites/CVS

...you can perform an anonymous checkout, create the redirects, produce a 
patch. and attach the patch to this bug.  If you choose to tackle this or if 
you need help, follow up on this bug report.
Comment 3 Dimitris Glezos 2006-10-12 20:45:55 EDT
Created attachment 138396 [details]
Patch that fixes redirections

Updated 36 files. If there was a corresponding wiki page, the redirection leads
there instead of the f.r.c page.

The following files were updated but still point to f.r.c pages because
respective wiki pages don't exist:

  * web/html/projects/desktop/index.php
  * web/html/projects/virtualization/index.php
  * web/html/projects/virtualization/index.php
  * web/html/participate/translation-faq/index.php
  * web/html/download/up2date-mirrors/index.php
  * web/html/download/mirrors/index.php

The following files were left unchanged and still don't redirect anywhere:

  * web/html/projects/cluster
  * web/html/projects/config-tools
  * web/html/projects/qa
Comment 4 Karsten Wade 2006-10-13 09:38:17 EDT
I'm happy to apply this patch, but I do not have a working sandbox to test it in.  

Can anyone confirm the patch works as expected?

We can also just apply it, see what breaks, and fix it as we go.  If Dimitris
wants to coordinate that with me (he and I doing the breaking and fixing), that
would be fine, too.  I mean, whatever we do will be *less* broken than it is
currently, right?
Comment 5 Dimitris Glezos 2006-10-13 12:42:38 EDT
Karsten, I'm OK with applying and fixing. I'll spend 3 minutes visiting the
webpages and checking if they work.
Comment 6 Karsten Wade 2006-10-13 13:16:24 EDT
OK, I'll apply the patch right now and commit.  It should go live at 17:45 UTC.
 I'll check back in to see if you have any fixes that need to be applied.

We should just get you access, but you need to apply for 'cvsfedora' group and I
don't have administration control of that group.  So, for now, I'll apply your
patches for you. :)
Comment 7 Dimitris Glezos 2006-10-13 17:18:25 EDT
Created attachment 138463 [details]
Patch 2 that makes 2 links of previous one better

Checked all the links, they are fine. Just 2 minor changes in the second patch,
could you please commit these too?
Comment 8 Patrick Barnes 2006-10-14 00:17:26 EDT
Dimitris now has CVS writing privileges for fedora/web/.
Comment 9 Karsten Wade 2006-10-14 01:05:58 EDT
OK, I applied the patch.

Please back up your local checkout, then confirm that everything now matches.  I
had some files with sticky tags that I didn't realize were in place, so I'm not
sure the first patch applied cleanly, although it said it did.  I worked from a
fresh checkout for the second patch, and that finally worked OK (hunks failed on
first attempt with files with sticky tags).

thx - Karsten
Comment 10 Patrick Barnes 2006-10-14 01:59:49 EDT
At a glance, it all looks right to me.

Dimitris, please take a minute to look and make sure everything is good.  If 
so, you can close this bug.
Comment 11 Dimitris Glezos 2006-10-14 08:27:03 EDT
Everything seems OK. Thanks Karsten and Patrick.

Unfortunately, I don't seem to have the privileges to close the bug.
Comment 12 Karsten Wade 2006-10-14 09:10:53 EDT
Great, thanks for the resolution.
Comment 13 Rahul Sundaram 2006-11-15 10:36:30 EST
*** Bug 175166 has been marked as a duplicate of this bug. ***
Comment 14 eric@christensenplace.us 2009-08-05 14:42:38 EDT
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.

Note You need to log in before you can comment on or make changes to this bug.