Bug 189095 - Incorrect globbing pulls extra sql dependencies in the main package
Incorrect globbing pulls extra sql dependencies in the main package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freeradius (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-15 21:46 EDT by Yanko Kaneti
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 09:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2006-04-15 21:46:21 EDT
%{_libdir}/rlm_sql*.so   in the main package files manifest includes all of
/usr/lib/rlm_sql_mysql-1.0.5.so
/usr/lib/rlm_sql_mysql.so
/usr/lib/rlm_sql_postgresql-1.0.5.so
/usr/lib/rlm_sql_postgresql.so
/usr/lib/rlm_sql_unixodbc-1.0.5.so
/usr/lib/rlm_sql_unixodbc.so

which we obviously don't want

Sugestion: change the glob to something like
-%{_libdir}/rlm_sql*.so
+%{_libdir}/rlm_sql-%{version}.so
+%{_libdir}/rlm_sql.so

This is also an issue with fc4 + updates.
Comment 1 Yanko Kaneti 2006-05-10 11:41:43 EDT
Lets change the severity to see if someone will notice.
Comment 2 Thomas Woerner 2006-06-01 09:53:45 EDT
Fixed in rawhide in rpm freeradius-1.1.1-1 or newer.

Note You need to log in before you can comment on or make changes to this bug.