Bug 189101 - rpc.lockd not locked down correctly by /etc/sysconfig/nfs
rpc.lockd not locked down correctly by /etc/sysconfig/nfs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-16 02:24 EDT by Ian Laurie
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-01 10:10:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2006-04-16 02:24:33 EDT
Description of problem:
rpc.lockd is not locked down correctly by the configuration file
/etc/sysconfig/nfs.  For example:

# /etc/sysconfig/nfs
STATD_PORT=4000
LOCKD_TCPPORT=4001
LOCKD_UDPPORT=4001
MOUNTD_PORT=4002
RQUOTAD_PORT=4003

Won't lock down rpc.lockd after a boot.  However it typically will if you issue
a "service nfs restart" command.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.8.rc2-4.FC5.2

How reproducible:
Always.

Steps to Reproduce:
1. Create above /etc/sysconfig/nfs file.
2. Reboot the system.
3. Issue "rpcinfo -p" command.
4. Issue "service nfs restart" command.
5. Issue "rpcinfo -p" command again and observe the difference.
  
Actual results:
rpc.lockd not locked down after a boot.

Expected results:
It should be locked down.

Additional info:

The problem is that although the control script /etc/rc.d/init.d/nfs references
the variables LOCKD_TCPPORT and LOCKD_UDPPORT, the /etc/rc.d/init.d/nfslock
script does not.  It seems what is in the nfs script isn't good enough....
perhaps because at the time the nfs script is trying to get rpc.lockd to lock
down its ports, rpc.lockd isn't running yet (or something like that as it works
with a restart).

This problem is in RHEL4 as well but was fixed with a patch.  The same patch
fixes FC5 also.  See bug 162133 for details.
Comment 1 Steve Dickson 2006-07-01 10:10:37 EDT
fixed in nfs-utils-1.0.8-3

Note You need to log in before you can comment on or make changes to this bug.