Bug 189168 - rc.sysinit tries to rm /var/run/cups, but /var/run/cups/certs is a directory
Summary: rc.sysinit tries to rm /var/run/cups, but /var/run/cups/certs is a directory
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 192208 192264 194557 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-17 20:25 UTC by Tom London
Modified: 2014-03-17 02:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 18:53:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2006-04-17 20:25:46 UTC
Description of problem:
Each boot, I get a message about 'unable to remove /var/run/cups'. Appears to
come from rc.sysinit's effort to clean out /var/run.

Cups seems to use /var/run/cups/certs/0 on my system, so the rm fails.

Should there be a special case in the 'Clean up /var' code for '*/cups)'?

Version-Release number of selected component (if applicable):
initscripts-8.32-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Austin Jackson 2006-05-17 15:45:19 UTC
I can confirm this with initscripts-8.31.1-1

Comment 2 Bill Nottingham 2006-05-18 17:08:35 UTC
*** Bug 192208 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2006-05-18 20:31:55 UTC
*** Bug 192264 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2006-05-23 18:53:42 UTC
Should be fixed in 8.34-1.

Comment 5 Hans de Goede 2006-05-24 11:11:56 UTC
I don't know if you want this in a seperate bug. But I just saw this in the
daily Rawhide Changelog mails and noticed that this was fixed with a special
case for cups.

I don't think a special case is the right solution. If it is please add a
special case for tiger. If you install tiger from FE it will create:
/var/run/tiger/work

Which causes the same problem.


Comment 6 Bill Nottingham 2006-05-24 15:53:36 UTC
Separate bug. I wonder if we need to have apps clean up their own. Or just
move/reimplement find.

Comment 7 Hans de Goede 2006-05-24 17:23:35 UTC
New bug filed: bug 192991.


Comment 8 Bill Nottingham 2006-06-30 19:25:58 UTC
*** Bug 194557 has been marked as a duplicate of this bug. ***

Comment 9 Michal Jaegermann 2006-07-06 19:27:16 UTC
This resurfaced, due to recent cups updates, in FC5 and it was
reported as bug 194557.  The later one was closed as a duplicate.
This indeed is fixed in the current rawhide but initscripts-8.31.4-1,
which is the most recent in testing for FC5 updates, is still missing
a corresponding cups 'case "$afile" in ...' entry.



Note You need to log in before you can comment on or make changes to this bug.