Bug 189182 - FAQ doesn't mention required package checkpolicy
FAQ doesn't mention required package checkpolicy
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 18:06 EDT by Stephen P. Schaefer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 23:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen P. Schaefer 2006-04-17 18:06:05 EDT
Description of problem:

The FC5 selinux FAQ does not mention the "checkpolicy" package, which was not
installed during an attempted reconstruction of an everything install with the
interactive installer.  It took me quite a while to discover that checkpolicy
this was the package containing the "checkmodule" command.

Version-Release number of selected component (if applicable):


How reproducible:

Read the FAQ.  Try to run "audit2allow" as specified.  Get
"/usr/bin/audit2allow: sh: checkmodule: command not found".  Have no clue where
to find that command.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Stephen P. Schaefer 2006-04-17 18:13:44 EDT
It occurs to me, since "audit2allow -M" requires checkmodule, perhaps the
policycoreutils RPM (containing audit2allow) should require the checkpolicy RPM
(containing checkmodule) to be loaded as well.
Comment 2 Daniel Walsh 2006-04-19 10:56:17 EDT
I am changing audit2allow to report an error when you use the -M qualifier and
you don't have checkmodule installed.  This will tell you which package to
install.  I don't really want to include this package by default, since
policycoreutils is on mininmal installs.

Does that sound acceptable?
Comment 3 Stephen P. Schaefer 2006-04-19 13:19:13 EDT
Yes; please do mention the package by name; I had tried searching for package
names containing "selinux" and that didn't find it.  Thanks.
Comment 4 Daniel Walsh 2006-05-23 23:49:24 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.