Bug 189186 - RPM scripts call /etc/rc.d/init.d/named directly
RPM scripts call /etc/rc.d/init.d/named directly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-17 22:13 EDT by Philip Rowlands
Modified: 2013-04-30 19:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-30 06:04:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Philip Rowlands 2006-04-17 22:13:04 EDT
I hope I can persuade you of the problem here; after the bind update released
today, I found environment leaks in the running named.

The reason (I think) is the way that the scripts use:
   /etc/rc.d/init.d/named condrestart >/dev/null 2>&1 || :

which bypasses the env-scrubbing behaviour of /sbin/service. This is bad, not
for any bind-specific effects I can put my finger on, but for the principle that
a daemon should *always* start in a consistent manner, irrespective of the "yum
update" it was restarted under or the user's particular locale.

In an unscientific survey, I count 32 uses of /sbin/service vs 8 calls with
/etc/init.d on the installed packages of my FC4 box.

Please consider using /sbin/service instead of /etc/rc.d/init/ in the RPM script.
Comment 1 Jason Vas Dias 2006-04-19 11:04:08 EDT
This bug is now fixed with bind-9.3.2-20.FC5, soon to be released to
FC-5 Updates / Testing.
 
Comment 2 Fedora Update System 2006-04-19 11:51:26 EDT
bind-9.3.2-20.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 3 Fedora Update System 2006-05-03 14:50:15 EDT
bind-9.3.2-20.FC5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 4 Adam Tkac 2007-05-30 06:04:15 EDT
Looks like fixed. If still exists, please reopen.

Regards, Adam

Note You need to log in before you can comment on or make changes to this bug.