Bug 189206 - [PATCH] crash of the backup conduit in gnome-pilot-2.0.13-7.fc5.5
[PATCH] crash of the backup conduit in gnome-pilot-2.0.13-7.fc5.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 189200 189205 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 08:04 EDT by Fabrice Bellet
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 19:12:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2006-04-18 08:04:49 EDT
Hi!,

gnome-pilot-2.0.13-7.fc5.5 in testing updates requires this one-liner fix, to
have the backup conduit work properly (because this part of the function may be
reached before pi_file_create() is called) :

--- gnome-pilot-2.0.13/conduits/backup/backup_conduit.c.orig    2006-04-18
12:48:19.000000000 +0200
+++ gnome-pilot-2.0.13/conduits/backup/backup_conduit.c 2006-04-18
12:49:02.000000000 +0200
@@ -591,7 +591,7 @@
  db_close:
        dlp_CloseDB (dbinfo->pilot_socket, dbinfo->db_handle);
  exit_and_free:
-       pi_file_close (f);
+       if (f) pi_file_close (f);
        g_free (name);
  exit:
        return result;
Comment 2 Frank Arnold 2006-04-20 02:19:52 EDT
*** Bug 189205 has been marked as a duplicate of this bug. ***
Comment 3 Frank Arnold 2006-04-20 02:20:13 EDT
*** Bug 189200 has been marked as a duplicate of this bug. ***
Comment 4 Fabrice Bellet 2006-04-20 19:12:02 EDT
fixed in an fc5-updates (bug #189294)

Note You need to log in before you can comment on or make changes to this bug.