Bug 189217 - can't update evolution using yum
can't update evolution using yum
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pilot-link (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 09:53 EDT by Hector Palacios
Modified: 2013-01-09 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-18 10:24:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hector Palacios 2006-04-18 09:53:03 EDT
Description:
I can't update evolution using yum.

Steps to Reproduce:
1. yum update evolution

Expected Results:  
evolution should install

Additional info:

> yum update evolution
Loading "changelog" plugin
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
updates                                                              [1/3]
core                                                                 [2/3]
extras                                                               [3/3]
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package evolution.i386 0:2.6.1-1.fc5.2 set to be updated
--> Running transaction check
--> Processing Dependency: libpisock.so.8 for package: evolution
--> Finished Dependency Resolution
Error: Missing Dependency: libpisock.so.8 is needed by package evolution

> uname -a
Linux efpc409.upf.es 2.6.16-1.2080_FC5smp #1 SMP Tue Mar 28 03:55:15 EST 2006
i686 i686 i386 GNU/Linux

> locate libpisoc
/usr/lib/libpisock.so.9
/usr/lib/libpisock.so.9.0.0

> rpm -qf /usr/lib/libpisock.so.9
pilot-link-0.12.0-0.pre4.5.2.1

> rpm -ql pilot-link|grep lib
/usr/lib/libpisock.so.9
/usr/lib/libpisock.so.9.0.0
/usr/lib/libpisync.so.0
/usr/lib/libpisync.so.0.0.2


seems to be similar to this bug of FC4:

+++ This bug was initially created as a clone of Bug #151109 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308
Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
up2date evolution produces the following output on my Rawhide system:

Unresolvable chain of dependencies:
evolution  2.0.2-3                       requires libebook.so.8
evolution  2.0.2-3                       requires libecal.so.6
evolution  2.0.2-3                       requires libedataserver.so.3
evolution  2.0.2-3                       requires libegroupwise.so.6
evolution  2.0.2-3                       requires libgal-2.2.so.1
evolution  2.0.2-3                       requires libgal-a11y-2.2.so.1
evolution  2.0.2-3                       requires libgtkhtml-3.1.so.11
evolution  2.0.2-3                       requires libpisock.so.8
gnome-pilot  2.0.12-4                    requires libpisock.so.8


Version-Release number of selected component (if applicable):
evolution-2.0.2-3

How reproducible:
Always

Steps to Reproduce:
1. up2date evolution, or yum install evolution


Actual Results:  evolution fails to be installed

Expected Results:  evolution should install

Additional info:

-- Additional comment from redhat@nodata.co.uk on 2005-03-16 05:35 EST --
I get a similar problem.
Installed FC4T1, Personal Desktop. Ran yum update; yum -y upgrade.

Now I get three missing dependencies, one of which is your
 "gnome-pilot  2.0.12-4                    requires libpisock.so.8"

I also get libwnck-1.so.4 needed by both usermode-gtk and gnome-applets.

-- Additional comment from skvidal@linux.duke.edu on 2005-03-29 02:32 EST --
temporary rawhide problem - now fixed.
Comment 1 Ngo Than 2006-04-18 10:24:51 EDT
the reverted pilot-link is now available in fc4/fc5-updates. The problem
should be fixed now.

Note You need to log in before you can comment on or make changes to this bug.