Bug 189220 - Satellite count error in gpsd
Satellite count error in gpsd
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gpsd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Truch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 10:12 EDT by Charles Curley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.32-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 22:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Curley 2006-04-18 10:12:00 EDT
Description of problem:

Continuous stream of error messages in /var/log/messages:

Apr 18 07:59:38 dragon gpsd[2534]: gpsd: GPGSV field 3 value of 7 != actual count 0 
Apr 18 07:59:43 dragon gpsd[2534]: gpsd: internal error - too many satellites! 
Apr 18 07:59:43 dragon gpsd[2534]: gpsd: internal error - too many satellites! 

Version-Release number of selected component (if applicable):

gpsd-2.32-4.fc5, gpsd-clients-2.32-4.fc5


How reproducible:

Always

Steps to Reproduce:
1. Plug in GPS receiver, fire up gpsd.
2. Observe logged messages.
3.
  
Actual results:

Continuous stream of error messages in /var/log/messages:

Apr 18 07:59:38 dragon gpsd[2534]: gpsd: GPGSV field 3 value of 7 != actual count 0 
Apr 18 07:59:43 dragon gpsd[2534]: gpsd: internal error - too many satellites! 
Apr 18 07:59:43 dragon gpsd[2534]: gpsd: internal error - too many satellites! 


Expected results:

No such errors.

Additional info:

This is on a Lenovo Thinkpad R51 (http://www.charlescurley.com/Lenovo.R51.html).
I had FC4 on it as noted on that web page. gpsd ran fine with no such messages.
I upgraded FC core via Anaconda, then updated that from updates released. gpsd
continued to run fine. I then upgraded extras, got the new gpsd, and that is
when I saw this problem.

gpsdrive appears to operate correctly.
Comment 1 Matthew Truch 2006-04-18 10:59:13 EDT
Interesting.  Could you give me a little more info before I look more into this:

- Exactly what kind of gps are you using?  
- Can you run gpsd with the -D4 option to turn up debugging output and provide
that?  Hint: If you run gpsd with the -N option it'll stay in the foreground and
spew logs to stdout instead of /var/log/messages.
- What previous version of gpsd were you running (when it worked)?  If you
didn't compile it yourself, where did you get the rpms/whatever?
Comment 2 Charles Curley 2006-04-18 13:18:10 EDT
Interesting.  Could you give me a little more info before I look more into this:

- Exactly what kind of gps are you using?

Global Satellites BU-353,
http://www.usglobalsat.com/item.asp?itemid=60&catid=17 It is SrIF III
and PL-2303 USB based, and has worked just fine since I got it in
December. It has an LED which flashes to indicate that it has a 3-D
fix; that was flashing at the time I was getting these error messages.

- Can you run gpsd with the -D4 option to turn up debugging output and provide
that?  Hint: If you run gpsd with the -N option it'll stay in the foreground and
spew logs to stdout instead of /var/log/messages.

[root@dragon ~]# gpsd -N -D4 /dev/ttyUSB0
gpsd: launching (Version 2.32)
gpsd: listening on port gpsd
gpsd: successfully connected to the DBUS system bus
gpsd: running with effective group ID 0
gpsd: running with effective user ID 0
gpsd: opening GPS data source at '/dev/ttyUSB0'
gpsd: Probing TrueNorth Compass
gpsd: hunting at speed 38400
gpsd: speed 38400, 8N1
gpsd: => GPS: @X?*67\x0d

gpsd: => GPS: @X?*67\x0d

gpsd: => GPS: @X?*67\x0d

gpsd: => GPS: @X?*67\x0d

....

gpsd: => GPS: @X?*67\x0d

gpsd: closing GPS=/dev/ttyUSB0 (5)
gpsd: Received terminating signal 2. Exiting...


- What previous version of gpsd were you running (when it worked)?  If you
didn't compile it yourself, where did you get the rpms/whatever?

I believe I got them from the gpsd web site.

-rw-rw-r-- 1 ccurley ccurley  205906 Sep 14  2005 down/gps/gpsd-2.30-1.i386.rpm
-rw-rw-r-- 1 ccurley ccurley   52628 Mar 23 21:56
down/gps/gpsd-clients-2.30-1.i386.rpm

[root@dragon log]# grep gpsd yum.log*
yum.log:Apr 17 14:37:02 Updated: gpsd.i386 2.32-4.fc5
yum.log:Apr 17 14:37:32 Updated: gpsd-clients.i386 2.32-4.fc5
yum.log.1:Mar 23 22:04:10 Installed: gpsd-clients.i386 2.30-1

I installed gpsd some time before March 23. I do recall it took me a
while to find out that the gpsd-clients package existed.
Comment 3 Charles Curley 2006-04-18 13:25:11 EDT
I had some problems w/ Bugzilla, so I emailed Matthew. My email, with his
responses interpolated, is below:

> Further information. I hauled in the gpsd 2.32 srpm from berlios.de,
> compiled it here, and installed the resulting RPMs.
> 
> * Compiling required that I install several -devel packages, and
>   libtool. I did not have to satisfy any dependencies to install the
>   two binary packages.

Of course.  Same goes for when the source is compiled by me (or in the
Fedora Extras buildsystem).

> * The xgps bug I reported appears to be partially an upstream bug. I
>   now see the satellite widget as too small, as I reported, but it and
>   the plot widget are populated. Do you want to report it or shall I?
>   You may have more clout with ESR et al. than I do.

Ok, so the xgps widget being small is definitely upstream.  I don't care
if you report it or not.  I doubt I have any more clout with ESR than
you do (unless you have already interacted with him).  I'll leave it up
to you; just let me know what you do.

> * The error messages do not show up.

Hmmmm.  This I find odd, since the source *should* be identical.  You
wouldn't happen to have a list of which -devel rpms you needed to
install, would you (so I can verify that I pull all that I need).
Did you compile from the source tarball, or just rebuild the src.rpm?
Unfortunately, I only have a garmin serial gps, so I am unable to test
for this case easily.
Comment 4 Charles Curley 2006-04-18 13:30:20 EDT
Here is what I installed this morning. It may not be all the devel packages I
needed, as some may have been installed before.

Apr 18 10:21:12 dragon yum: Installed: libjpeg-devel.i386 6b-36.2.1
Apr 18 10:21:13 dragon yum: Installed: libpng-devel.i386 2:1.2.8-2.2.1
Apr 18 10:21:25 dragon yum: Installed: openmotif-devel.i386 2.3.0-0.1.9.2
Apr 18 10:21:30 dragon yum: Installed: ncurses-devel.i386 5.5-19
Apr 18 10:22:08 dragon yum: Installed: autoconf.noarch 2.59-7
Apr 18 10:22:10 dragon yum: Installed: automake.noarch 1.9.6-2
Apr 18 10:22:40 dragon yum: Installed: libtool.i386 1.5.22-2.2

As for testing, if you get something to test, put an RPM or tarball where I can
ftp or http it in & I'll test it.

Comment 5 Matthew Truch 2006-04-19 16:06:11 EDT
Ok, after some offling back and forth, the problem comes down to the
--enable-tnt to enable the TNT gps driver.  This seems to conflict with other
drivers.  I'm disabling it for now (it isn't enabled by default, so really I'm
omitting my explicit enable).  Fixed in version 2.32-5 which has been pushed
through the buildsystem.  

Note You need to log in before you can comment on or make changes to this bug.