This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 189234 - ccsd may choose the wrong block device and broke it
ccsd may choose the wrong block device and broke it
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 10:50 EDT by Alban Crequy
Modified: 2009-04-16 16:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-25 10:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alban Crequy 2006-04-18 10:50:21 EDT
Description of problem:
In the init script /etc/init.d/ccsd, may autodetect the CCA block device to use
with pool_tool -s | awk '/CCA device /{print $1}'
If there is several CCA block device detected by pool_tool, ccsd will choose the
first one.

I think this is too dangerous to use the first cca block device that *may* be
the cca to use. Maybe the user set up several cca block device for testing
purpose and they must not be used automatically. Maybe another block device
matches the magic number test of pool_tool. Maybe pool_tool will take /dev/sda
because this device looks like a CCA.

I fear that ccsd broke another device if this block device happen to look like a
CCA device.


Version-Release number of selected component (if applicable):
GFS-6.0.2.27-0

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jonathan Earl Brassow 2006-07-25 10:26:17 EDT
Would it help to know that that device will never be written to?  The only way
the contents of the device will be altered is if you use 'pool_tool', and then
you would have to specify the device to alter.

In the worst case, the wrong CCA may be selected; causing the node to try to
join a cluster which may not exist - and probably fail the join.  You should
never have a problem with overwritten devices.

If you have more concerns, feel free to post; otherwise, marking this bug WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.