This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 189266 - gnome-terminal crashes on startup with GDK_IS_SCREEN (screen) assertion
gnome-terminal crashes on startup with GDK_IS_SCREEN (screen) assertion
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 13:58 EDT by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-25 16:53:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-04-18 13:58:13 EDT
Description of problem:
gnome-terminal crashes on startup, with an assertion failure (see below), then a
segfault

Version-Release number of selected component (if applicable):
gnome-terminal-2.14.1-8
(with a rawhide X server, with compositing enabled)

How reproducible:
100% for me at the moment

Steps to Reproduce:
1. Running a gnome session, with compositing enabled in metacity
2. Start gnome-terminal

  
Actual results:
Starting program: /usr/bin/gnome-terminal 
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xbdf000
[Thread debugging using libthread_db enabled]
[New Thread -1208383824 (LWP 2700)]
GTK Accessibility Module initialized
Bonobo accessibility support initialized

(gnome-terminal:2700): Gdk-CRITICAL **: gdk_screen_get_number: assertion `GDK_IS
_SCREEN (screen)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208383824 (LWP 2700)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x0806a82d in terminal_screen_reread_profile (screen=0x91f7330)
    at terminal-screen.c:611
#2  0x0806aa47 in terminal_screen_set_profile (screen=0x91f7330, 
    profile=0x92361d0) at terminal-screen.c:959
#3  0x0805dfc6 in terminal_app_new_terminal (app=0x922c738, profile=0x92361d0, 
    window=0x9249030, screen=0x91f7330, force_menubar_state=0, 
    forced_menubar_state=0, start_fullscreen=0, override_command=0x0, 
    geometry=0x0, title=0x0, working_dir=0x0, role=0x0, zoom=1, 
    startup_id=0x921eb88 "_TIME2921766964", display_name=0x921f1d8 ":0.0", 
    screen_number=0) at terminal.c:1951
#4  0x0805eafc in new_terminal_with_options (results=0x91dc930)
    at terminal.c:1433
#5  0x0805f79b in main (argc=7, argv=0xbfcb5554) at terminal.c:1761
#6  0x00c127e4 in __libc_start_main () from /lib/libc.so.6
#7  0x08054891 in _start ()
Comment 1 Kjartan Maraas 2006-04-25 13:50:52 EDT
I changed the transparency patch a bit and uploaded a new src.rpm which works
for me at http://www.gnome.org/~kmaraas/gnome-terminal-2.14.1-10.src.rpm
Comment 2 Kristian Høgsberg 2006-04-25 16:53:23 EDT
Kjartan, thanks for the fix.  I updated it a bit more to use GDK for getting the
selection owner and rebuilt the package.  Closing bug.
Comment 3 Zuirdj 2006-05-04 22:23:08 EDT
I have this problem with gnome-terminal-2.14.1-7 from FC5 updates-testing repo,
since vte was updated (vte-0.12.1-1.fc5.1)

[zuirdj@pinina ~]$ gnome-terminal

(gnome-terminal:6432): Gdk-CRITICAL **: gdk_screen_get_number: assertion
`GDK_IS_SCREEN (screen)' failed

Note You need to log in before you can comment on or make changes to this bug.