Bug 189281 - syck-python missing 'dump' function
syck-python missing 'dump' function
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: syck (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Oliver Falk
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 15:30 EDT by Michael DeHaan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-28 02:51:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael DeHaan 2006-04-18 15:30:28 EDT
Description of problem:

syck-python in fc5 does not present the 'dump' function, needed for YAML
serialization.  See http://pyyaml.org/ticket/2

Version-Release number of selected component (if applicable):

syck-python.i386                         0.55-7.fc5    

How reproducible:

Steps to Reproduce:
1.  install syck
2.  pydoc syck

Actual results:

Syck doesn't have a dump function

Expected results:

Syck would have a dump function, as referenced by most syck-python examples (see
google). 

Additional info:

http://pyyaml.org/ticket/2
Comment 1 Jeff Johnson 2006-05-03 18:10:47 EDT
You might look at
    http://wraptastic.org/pub/i386-linux/SRPMS/PySyck-0.61.2.1.src.rpm
WORKSFORME, there's a syck-0.61-1.src.rpm there as well.

No I'm not interested in adopting ...
Comment 2 Michael DeHaan 2006-05-03 18:26:55 EDT
To clarify "WORKSFORME" doesn't refer to the original package.  

Unless there's an open bugzilla for the inclusion of PySyck above, I am
currently trying to get an alternative to the broken package approved. 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190493

I'd really be happier with either version in extras, though I chose to put my
foot behind the YAML 1.1 compliant version, regardless of what I think of YAML
not needing a 1.1 ... PySyck is apparently a dead end according to pyyaml.org.


Comment 3 Jeff Johnson 2006-05-03 18:35:47 EDT
PySyck works today, and works well.

FWIW, the lack of dump in syck-python could probably be repaired quickly if anyone really cared.

But you appear to want the Latest and Greatest Next Generation Whizbanger if you are claiming "dead 
end". It's not like YAML is widely used, bits and patches litter about ...
Comment 4 Jeff Johnson 2006-05-03 18:39:39 EDT
BTW, there's also lsyck.c within syck, I know of no other replacement for that.

Also FYI, syck-0.61 (and lsyck) is integrated into rpm-4.4.7. PySyck if the need arises.
Comment 5 Michael DeHaan 2006-05-04 09:59:12 EDT
"But you appear to want the Latest and Greatest Next Generation Whizbanger if
you are claiming "dead end"

Perhaps there was a communication error.  

If this is about PyYaml vs SyckPython, it seems like here: 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190493 is a better place to
talk about that.  I am not talking about orphaning syck and the C bindings that
RPM uses at all, I am only reporting that "syck-python" is broken. 
 
"FWIW, the lack of dump in syck-python could probably be repaired quickly if
anyone really cared."

PySyck is a result of someone caring about this.  Since you've packaged it, why
not submit it for Extras?   Extras needs a replacement yaml parser, and I would
not loose sleep over having to use PySyck vs PyYaml.


Comment 6 Jeff Johnson 2006-05-05 22:04:34 EDT
POI: there are 3 implementations of yaml for python:
     syck-python
     PySyck
     PyYAML

syck-python appears broken, but there are other reasons, such as ruby/lua YAML,
to continue syck even if syck-python is borked.

PySyck is an alternative, more featureful, python bindings for syck.

PyYAML is probably the most complete YAML implementation for python.

And rpm depends on none of the above, has an internal copy of lsyck.c and
syck-0.61 instead.

I prefer being a non-Fedora contributor.
Comment 7 Michael DeHaan 2006-05-08 10:23:36 EDT
"syck-python appears broken, but there are other reasons, such as ruby/lua YAML,
to continue syck even if syck-python is borked."

All true. 

Regarding the other 'zilla, given that pretty much all Perl/Ruby/Lua/Etc
implementations are doing YAML 1.0 (nothing wrong with that), PySyck is probably
a better answer *now* than PyYAML.  I'm going to kill the other 'zilla, and if
someone wants to fix this, my recommendation is replacing the syck-python RPM
with PySyck.
Comment 8 Oliver Falk 2007-03-14 06:25:45 EDT
Kick out -python from syck now!?
Comment 9 Oliver Falk 2007-08-27 04:17:51 EDT
Can you have a look at the latest syck pkg in rawhide?
Comment 10 Michael DeHaan 2007-08-27 11:21:21 EDT
I don't have a rawhide setup ATM.  If the function is available in rawhide I'd
say we can close it -- though it would be nice to see the fix also pushed to F7.

(FWIW, I ended up embedding an older yaml serializer in my app for backwards
compatibility reasons.)
Comment 11 Oliver Falk 2007-08-28 02:51:18 EDT
Currently, the pydoc doesn't say anything about the dump function, but looking
at the pkg content there is a ydump, that defines the dump function. I close it
for now...

Note You need to log in before you can comment on or make changes to this bug.