Bug 189285 - Can not mount >256 file systems: can't read superblock
Can not mount >256 file systems: can't read superblock
Status: CLOSED DUPLICATE of bug 189283
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 16:19 EDT by Robinson Tiemuqinke
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 02:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robinson Tiemuqinke 2006-04-18 16:19:32 EDT
Description of problem:

 Could not mount many active file systems at the same time, the error output 
is "can't read superblock".

Version-Release number of selected component (if applicable):

 All stock FC4/FC5 kernel show the same problem. 

How reproducible:

 Every time.

Steps to Reproduce:

1. Install a FC4 or FC5 system ( my output is based on FC4 system)
2. have other bunches of systems with NFS shares ready.
3. try to run a loop to mount NFS file systems on the newly installed FC4 
system.
  
Actual results:



[root@testMaster ~]# for i in `/example/bin/lsng testnode-hosts`; do echo 
${i}; mount ${i}:/0 /0/ttt/${i}/0; mount ${i}:/1 /0/ttt/${i}/1;  mount 
${i}:/2 /0/ttt/${i}/2; mount ${i}:/3 /0/ttt/${i}/3; done

...
testnode540
testnode541
testnode542
testnode543
mount: testnode543:/1: can't read superblock
mount: testnode543:/2: can't read superblock
mount: testnode543:/3: can't read superblock
testnode544
mount: testnode544:/0: can't read superblock
mount: testnode544:/1: can't read superblock
mount: testnode544:/2: can't read superblock
mount: testnode544:/3: can't read superblock
testnode545
mount: testnode545:/0: can't read superblock
mount: testnode545:/1: can't read superblock
mount: testnode545:/2: can't read superblock
mount: testnode545:/3: can't read superblock
testnode546
mount: testnode546:/0: can't read superblock
mount: testnode546:/1: can't read superblock
mount: testnode546:/2: can't read superblock
mount: testnode546:/3: can't read superblock
testnode547
mount: testnode547:/0: can't read superblock
mount: testnode547:/1: can't read superblock
mount: testnode547:/2: can't read superblock
mount: testnode547:/3: can't read superblock
testnode548
mount: testnode548:/0: can't read superblock
mount: testnode548:/1: can't read superblock
mount: testnode548:/2: can't read superblock
mount: testnode548:/3: can't read superblock
testnode549
...

[root@testMaster ~]# df -k | wc -l
254
[root@testMaster ~]#

[root@testMaster ~]# uname -a
Linux testMaster.example.com 2.6.15-1.1831_FC4smp #1 SMP Tue Feb 7 13:51:52 
EST 2006 x86_64 x86_64 x86_64 GNU/Linux
[root@testMaster ~]#




Expected results:

 It should mount all 1000 NFS file systems without problems.


Additional info:
Comment 1 Frank Arnold 2006-04-20 02:12:35 EDT

*** This bug has been marked as a duplicate of 189283 ***

Note You need to log in before you can comment on or make changes to this bug.