Bug 189304 - kile: crashes with Segmentation fault
kile: crashes with Segmentation fault
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kile (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-18 19:46 EDT by João Mauricio de O. Alves
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 21:34:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description João Mauricio de O. Alves 2006-04-18 19:46:57 EDT
Description of problem:
Kile is not starting. Every time I try, it crashes with a Segmentation Fault.
Does not matter if I try the icon or the command line.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep kile
kile-1.9-1.fc5

How reproducible:
Always


Steps to Reproduce:
1. Just start it.
$ kile

Actual results:
Segmentation fault

Expected results:
The program running

Additional info:
I am using a fully update Fedora Core 5 system
$ date -u
Tue Apr 18 23:52:31 UTC 2006

uname -a
Linux localhost 2.6.16-1.2080_FC5 #1 Tue Mar 28 03:38:34 EST 2006 i686 athlon
i386 GNU/Linux

(I changed the name of the host in the message only)
------------
$ valgrind kile
==2706== Memcheck, a memory error detector.
==2706== Copyright (C) 2002-2005, and GNU GPL'd, by Julian Seward et al.
==2706== Using LibVEX rev 1471, a library for dynamic binary translation.
==2706== Copyright (C) 2004-2005, and GNU GPL'd, by OpenWorks LLP.
==2706== Using valgrind-3.1.0, a dynamic binary instrumentation framework.
==2706== Copyright (C) 2000-2005, and GNU GPL'd, by Julian Seward et al.
==2706== For more details, rerun with: -v
==2706==
==2706== Invalid read of size 4
==2706==    at 0x36DAD4: _dl_relocate_object (in /lib/ld-2.4.so)
==2706==    by 0x366832: dl_main (in /lib/ld-2.4.so)
==2706==    by 0x37656A: _dl_sysdep_start (in /lib/ld-2.4.so)
==2706==    by 0x36548E: _dl_start (in /lib/ld-2.4.so)
==2706==    by 0x363846: (within /lib/ld-2.4.so)
==2706==  Address 0xC49CCE0 is not stack'd, malloc'd or (recently) free'd
==2706==
==2706== Process terminating with default action of signal 11 (SIGSEGV)
==2706==  Access not within mapped region at address 0xC49CCE0
==2706==    at 0x36DAD4: _dl_relocate_object (in /lib/ld-2.4.so)
==2706==    by 0x366832: dl_main (in /lib/ld-2.4.so)
==2706==    by 0x37656A: _dl_sysdep_start (in /lib/ld-2.4.so)
==2706==    by 0x36548E: _dl_start (in /lib/ld-2.4.so)
==2706==    by 0x363846: (within /lib/ld-2.4.so)
==2706==
==2706== Jump to the invalid address stated on the next line
==2706==    at 0x1D6: ???
==2706==    by 0x43C438F: ???
==2706==    by 0x366832: dl_main (in /lib/ld-2.4.so)
==2706==    by 0x37656A: _dl_sysdep_start (in /lib/ld-2.4.so)
==2706==    by 0x36548E: _dl_start (in /lib/ld-2.4.so)
==2706==    by 0x363846: (within /lib/ld-2.4.so)
==2706==  Address 0x1D6 is not stack'd, malloc'd or (recently) free'd
==2706==
==2706== Process terminating with default action of signal 11 (SIGSEGV)
==2706==  Bad permissions for mapped region at address 0x1D6
==2706==    at 0x1D6: ???
==2706==    by 0x43C438F: ???
==2706==    by 0x366832: dl_main (in /lib/ld-2.4.so)
==2706==    by 0x37656A: _dl_sysdep_start (in /lib/ld-2.4.so)
==2706==    by 0x36548E: _dl_start (in /lib/ld-2.4.so)
==2706==    by 0x363846: (within /lib/ld-2.4.so)
==2706==
==2706== ERROR SUMMARY: 2 errors from 2 contexts (suppressed: 32 from 1)
==2706== malloc/free: in use at exit: 0 bytes in 0 blocks.
==2706== malloc/free: 0 allocs, 0 frees, 0 bytes allocated.
==2706== For counts of detected errors, rerun with: -v
==2706== No malloc'd blocks -- no leaks are possible.
Segmentation fault


------------
$ rpm -qi kile
Name        : kile                         Relocations: (not relocatable)
Version     : 1.9                               Vendor: Fedora Project
Release     : 1.fc5                         Build Date: Mon 03 Apr 2006 10:44:15
AM BRT
Install Date: Sat 15 Apr 2006 01:09:02 AM BRT      Build Host:
hammer1.fedora.redhat.com
Group       : Applications/Publishing       Source RPM: kile-1.9-1.fc5.src.rpm
Size        : 9573385                          License: GPL
Signature   : DSA/SHA1, Mon 03 Apr 2006 11:07:41 AM BRT, Key ID 82ed95041ac70ce6
Packager    : Fedora Project <http://bugzilla.redhat.com/bugzilla>
URL         : http://kile.sourceforge.net/
Summary     : (La)TeX source editor and TeX shell
Comment 1 Rex Dieter 2006-04-19 08:19:17 EDT
Thanks for the report, though you're the first to report problems and it
WORKSFORME on my fc5 box.
Comment 2 João Mauricio de O. Alves 2006-04-20 21:34:44 EDT
After your comment, I installed my box again. I cannot reproduce the bug anymore.
I installed with the DVD first. This time I took the following steps:

1) Burn disc1
2) Boot with disc1. Install from CD isos in the second HD
3) install kile (via yum). It is OK
4) Fully update the system. It is OK
5) Install amule and mplayer. Is is OK too.

I think the bug can be closed. It WORKSFORME too, now.
Perhaps there was something corrupted in my HD before I install the FC5 again.

Sorry for the inconvinient,
João Mauricio
Comment 3 Rex Dieter 2006-04-20 23:22:32 EDT
No problem, I'm glad you've got a happier, working system now.  :)

Note You need to log in before you can comment on or make changes to this bug.