Bug 189321 - Ghostscript does not work with emacs in FC5
Ghostscript does not work with emacs in FC5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 00:52 EDT by Martin Donald
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 8.15.2-1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 07:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.ps file made my emacs 'ps-spool-buffer' command (31.94 KB, text/plain)
2006-04-19 00:52 EDT, Martin Donald
no flags Details

  None (edit)
Description Martin Donald 2006-04-19 00:52:02 EDT
Description of problem:Files produced by emacs ps-print facility fail in
ghostscript-8.15.1-7.2


Version-Release number of selected component (if applicable): ghostscript-8.15.1-7.2


How reproducible:Solid


Steps to Reproduce:
1.In emacs: 'ps-spool-buffer' to make poscript file, or 'ps-print-buffer' to
send direct to the printer
2.Try to print file made by 'ps-spool-buffer', e.g. 'lpr t2-home.ps'
3.
  
Actual results:
# Error: configurationerror
# OFFENDING COMMAND: setpagedevice

# STACK:

-dictionary-

# ERRORINFO:

false
/ManualFeed



Expected results: A simple postscript printout


Additional info:# Error: configurationerror
# OFFENDING COMMAND: setpagedevice

# STACK:

-dictionary-

# ERRORINFO:

false
/ManualFeed

Additional info:
Files made at my workplace (RHEL3) and home (FC5) fail to work at home but print
fine at work (ghostscript-7.05)

I reported the bug at  bugs.ghostscript.com (#688654) and it was confirmed as
version dependent. 

http://bugs.ghostscript.com/show_bug.cgi?id=688654

htl10@users.sourceforge.net changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|                            |INVALID



------- Additional Comments From htl10@users.sourceforge.net  2006-04-16 12:44
-------
Since the current v8.53 work just fine, and the problem belongs
to EPS ghostscript which is maintained by the CUPS people rather than
the ghostscript folks, please file the problem at www.cups.org instead.
AFPL 8.14 also works just fine.

BTW I had this response from ghostscript in a matter of minutes on Easter
Sunday. They are really on the ball.


It was suggested that I report to cups.org who maintain that version. I reported
the bug (STR 1570) but got no action.

I attach my test file 't2-home.ps' which was made by ps-print from an 8-line
text file
Comment 1 Martin Donald 2006-04-19 00:52:02 EDT
Created attachment 127972 [details]
.ps file made my emacs 'ps-spool-buffer' command
Comment 2 Martin Donald 2006-04-22 22:17:44 EDT
I have heard today from Michael Sweet of cups.org that the problem is fixed in
the subversion repository.

Will we be getting an update for FC5?

Martin.
Comment 3 Martin Donald 2006-04-22 22:33:43 EDT
Here is the email from Michael Sweet

To: Martin Donald <mhd@slac.stanford.edu>
Subject: Re: [HIGH] STR #1570: Emacs ps-print files no longer work in gs
From: Michael Sweet <mike@easysw.com>
Reply-To: cups-bugs@easysw.com
Cc: Martin Donald <mhd@slac.stanford.edu>
Cc: cups-bugs@easysw.com
Date: Sat, 22 Apr 2006 21:01:37 -0400 (EDT)
X-PMX-Version: 4.7.1.128075, Antispam-Engine: 2.3.0.1, Antispam-Data:
2006.4.22.173107
X-PerlMx-Spam: Gauge=IIIIIII, Probability=7%, Report='__CP_URI_IN_BODY 0, __CT
0, __CT_TEXT_PLAIN 0, __HAS_MSGID 0, __MIME_TEXT_ONLY 
+0, __MIME_VERSION 0, __SANE_MSGID 0'


[STR Closed w/Resolution]

Fixed in Subversion repository.

Link: http://www.cups.org/str.php?L1570
Version: 8.15.1
Fix Version: 8.15-current (r135)
Comment 4 Tim Waugh 2006-04-24 12:26:51 EDT
Fix built in devel.

Fixed in CVS for FC-5.  Holding off update until timetable for 8.15.2 is clearer.
Comment 5 Tim Waugh 2006-04-26 11:06:25 EDT
Please try this test update:

https://www.redhat.com/archives/fedora-test-list/2006-April/msg00546.html
Comment 6 Martin Donald 2006-04-26 16:34:03 EDT
ps-print works fine now with ghostscript-8.15.2-1.1

Thanks everyone.

Martin.

Note You need to log in before you can comment on or make changes to this bug.