Bug 189371 - install script errors
install script errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-19 11:41 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-20 10:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-04-19 11:41:04 EDT
Description of problem:

Installing 2:2.2.11-0.fc5.1 from updates-testing gives the following errors:

Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

repeated 4 times each.  Error is coming from /usr/sbin/xsane-install-gimp-plugin
which calls /usr/bin/gimptool-2.0 --gimpplugindir, which does:

++ pkg-config --cflags gtk+-2.0
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found


Looks like some missing Requires(pre/post), or better yet fix gimptool-2.0 to
not call pkg-config unless it needs to (it doesn't for --gimpplugindir and
--version).
Comment 1 Nils Philippsen 2006-04-20 10:48:44 EDT
fixed in gimp-2.2.11-0.fc5.3 -- the included gimptool should no longer call
pkgconfig if not needed.

Note You need to log in before you can comment on or make changes to this bug.