Bug 189372 - cmucl: segfaults
Summary: cmucl: segfaults
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: cmucl (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-19 15:41 UTC by Mikko Huhtala
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-05 12:10:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikko Huhtala 2006-04-19 15:41:10 UTC
Description of problem:

  cmucl compiler/interpreter segfaults upon start

Version-Release number of selected component (if applicable):

  cmucl-19c-4.fc5

How reproducible:

  always

Steps to Reproduce:

  1. Install cmucl
  2. Run 'lisp' or 'cmucl'

  
Actual results:

  Error message:

  Couldn't mmap at 0x10000000, len 268431360; got mapping at 0xff00000
insteadSegmentation fault


Expected results:

  Proper start of the CMU Common Lisp environment.

Comment 1 Mikko Huhtala 2006-04-19 15:44:02 UTC
Sorry, forgot to mention that this is on an up-to-date FC5 with

  glibc-2.4-4

  kernel-2.6.16-1.2080_FC5


Comment 2 Rex Dieter 2006-04-19 15:56:10 UTC
Thanks for the report.

Comment 3 Rex Dieter 2006-05-24 17:42:38 UTC
WORKSFORME, on my fc5 boxes.

$ rpm -q cmucl glibc
cmucl-19c-4.fc5
glibc-2.4-8

$uname -r
2.6.16-1.2111_FC5

Please update glibc/kernel and try running cmucl again.  Let me know if that
helps or not.

Comment 4 Mikko Huhtala 2006-06-05 10:53:39 UTC
Sorry about slow reply. It now works for me too. This is using

cmucl-19c-4.fc5
glibc-2.4-8
kernel 2.6.16-1.2122_FC5 #1 Sun May 21 15:01:01 EDT 2006 i686 i686 i386 GNU/Linux



Comment 5 Rex Dieter 2006-06-05 12:10:07 UTC
Glad to here it.


Note You need to log in before you can comment on or make changes to this bug.