Bug 189378 - Dovecot should ship with config "mail_extra_groups = mail"
Summary: Dovecot should ship with config "mail_extra_groups = mail"
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dan Horák
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-04-19 16:05 UTC by Oliver Schulze L.
Modified: 2008-08-11 08:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 08:48:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oliver Schulze L. 2006-04-19 16:05:34 UTC
Description of problem:
Since RHEL4 ships with a default mail environment that uses mbox with dovecot,
dovecot should be configured to have this configuration as default in
/etc/dovecot.conf:
mail_extra_groups = mail

Version-Release number of selected component (if applicable):
dovecot-0.99.11-2.EL4.1

How reproducible:
having imap as a backend



Steps to Reproduce:
1. Create a new user with an ldap backend 
2. check your email using dovecot imap
  
Actual results:
- you see in /var/log/maillog:
Apr 19 10:45:16 iserver imap(username): open(/var/mail/username, O_CREAT)
failed: Permission denied


Expected results:
the file /var/mail/usernam is created

Additional info:
The issue is solved by configuring en /etc/dovecot.conf
mail_extra_groups = mail

Comment 1 Dan Horák 2008-08-11 08:48:31 UTC
Closing as NOTABUG to keep consistency with upstream.


Note You need to log in before you can comment on or make changes to this bug.